Community Blog Buy Now

Misty Community Forum

Trouble AV streaming to VLC

I’m having trouble with this. I am following the instructions, and the tally light comes on, but VLC does not show any video. If I hit play, VLC searches for a moment and then stops.

Also, when I stop av streaming, the tally light stays on. I have to disable avstreamingservice, then re-enable, and then disable again.

Thanks for any help you can provide!

What host OS are you on (e.g., Mac, Windows, some distribution of Linux)? What version of VLC?

It’s possible the streaming service is hanging on something.

Do you know how to use adb? Here’s how to install it:

The most useful thing would be to grab the adb logs for the streaming service and send to me. Here’s how:

  • Open up a command line or terminal
  • adb connect <ROBOT_WIFI_IP>:5555
  • adb shell ps -ef | grep misty
  • You should see something like this:
root          2900     1 0 18:30:32 ?     00:01:46 sh /data/misty/scripts/
system        9815   846 0 21:43:10 ?     00:00:15 com.mistyrobotics.sensoryservices
system        9835   846 0 21:43:10 ?     00:00:01 com.mistyrobotics.sensoryservices:audioService
system        9862   846 0 21:43:10 ?     00:00:04 com.mistyrobotics.sensoryservices:computerVision
system       10254   846 3 21:43:45 ?     00:05:47 com.mistyrobotics.sensoryservices:slamService
system       12532   846 1 00:47:02 ?     00:00:00 com.mistyrobotics.sensoryservices:streamingService
  • Note the process ID for the streaming service. In the example above it’s 12532
  • Then do adb logcat --pid 12532 -d > streaming_logcat.txt after you’ve tried to start streaming and connecting via vlc
  • Send that file

Actually, it just occurred to me that if you ran the Android update patch from a few months ago ADB over wifi is disabled by default, so you might not be able to do the above without a USB to Ethernet.

Let’s start with your OS and VLC version and VLC settings like Scott asked. Also please include the settings you are using to start streaming.

OK! It’s working now. Weird.

I’m using Win10 with VLC 3.0.8.

I can do adb over wifi because I re-enabled that after installing the recent patch. The grep command above didn’t work for me, but I could scroll through Misty’s processes anyway.

When I first enabled the streaming service and ran adb, the streaming service did not appear as a process. So, I enabled the streaming service again and it showed up. After that, streaming to VLC started working!

I stopped streaming and the tally light went off. Yay!

I disabled AV streaming and got a “true” response, but I got the following error in the console:

DevTools failed to parse SourceMap:

I tried disabling a couple of times, and it still shows as a process in adb.

Anyways, I will keep practicing with it so I don’t have to go into adb every time.

Thanks so much for your help!!

Yea on Android, disabling a process doesn’t actually kill it, it puts it in a zombie state where it’s been shutdown but it’s still ready to be brought back up. It’s one of the many things Android thinks it’s being clever about but really it’s just a pain. So even if you disable he service it will still show in process list but if you were to logcat that process you’d see it has had its deallocator called.

The newest release has a small fix to shut down the tally light if the streaming process crashes for whatever reason.