Robot Engage Blog Buy Now

Misty Community Forum

[RESOLVED] LED and locomotion no longer work

I was playing with my Misty yesterday and everything worked well. I could drive him with the companion app and Javascript API. I could change eyes, changed LED and get a map with SLAM.

Today I started trying to do the face detection commands (which I could not get figured out - but that’s for another post). Not longer after, I could no longer change the LED or get any locomotion commands to work. This is different than when the left wheels didn’t work. It seems like the commands are not getting processed by the robot at all. Display commands still work (eyes, show image) and I can still get a map with SLAM. So I definitely have a working connection to the Misty.

What I’ve noticed and tried:

Misty randomly rebooted a number of times this morning. This had not happened on previous days.
I’ve tried turning him on/off, power cord/no power cord.
Tried Javascript API for locomotion and iOS companion app.

@Steven replaced a board in Misty when he was fixing my left wheels. It looks like the LED plugs into that board, and I’m assuming that board also controls the wheels. So my hunch is something is going on with that board maybe?

Any suggestions on things I should try?

Hi Cameron,

You’re correct, the LED and Drive wheels are controlled by the same board (the RTC), while the display and SLAM system are handled by different boards. So it sounds like either communication to the RTC has gone awry, or the board itself is having issues.

One (first) thing to check is that the communication cable between the main processor and the RTC is still firmly connected, with no broken wires. On your Misty, locate the 410 board (it’s the one with the HDMI cable that’s not in the head), and check the wires coming off of it. Also make sure that the RTC and attached Motor Control boards have their LEDs on and blinking.

The rebooting - was it just the app starting up again (Misty splash screen, then eyes), or was it the processor restarting (Qualcomm Snapdragon splash screen, then Misty, then eyes)? The latter would suggest power issues, while the former is more likely a known bug (possibly brought on by the communication issue).


1 Like

Hmmmm. I’m not sure which is the 410 board. Is the green board in the attached picture the “Motor Control board”? I think I traced the wires from this board to the motors. What is the blue board? And what is the board that the Motor Control board is attached too (the one directly behind it)?

I noticed the green board in the photo attached was a little loose in it’s connection to the board directly behind it. I pulled the green board out and snuggley connected it again, but it made no change.

In terms of restarts, it’s just Misty splash, then eyes (no snapdragon).


Thanks for the picture Cameron,

The blue board with the HDMI cable coming out of it is the 410 board. On the right hand side there is a connector with a lot of hot glue on it, this is the SPI cable connecting the 410 to the RTC, which should be the board in the back. The one in the middle (the green board) should be the motor control board like you said.

Please check that SPI connection to make sure the 410 is connected to the RTC. Additionally, both the RTC and MC boards should have LEDs on them that start blinking once the robot is on.

Glad to hear there is no snapdragon splash on your restarts - it’s likely not a power issue then. Other than the few this morning, are they still happening?



Yeah Dan had a great suggestion to check the three LEDs to see what their behavior is. There are two on the RT board (the one buried in the back), and one on the MC board. All 3 are red. The behaviors are:

LED 1 on the RT board is power. It is near the top of the board (closest to the head) It will be on whenever those two green boards are given power. It should always be solid on. If you see it flickering there could be a power problem.
LED 2 on the RT board is charging indicator. It is buried further down toward the wheels, so is sometimes difficult to see. It should be ON when the robot is charging, off when its charged, and blinking (on-off-on-off) or (bright-dim-bright-dim) if its in a fault (you should never see it blinking or you need to tell us).
LED 3 is on the MC board and is visible in the picture you took above (though not on at the moment). It should be blinking very rapidly when the system is powered and working.

Can you tell us what the LEDs are doing? That’ll be a good start.

Thanks for working with us on this! This type of interaction and feedback is great for us!


Thanks for explaining all the boards, @dan and for the suggestions.

I tinkered around for awhile. I’m not sure really what I did, but it magically started working again!

So I’ve been driving my Misty all around the house for awhile.

I noticed the tracks get jammed VERY easily. I’m on hard-wood floors, but basically any time I made a turn one of them would start jamming up, and I could hear sounds from the motor like it was straining. My guess is this is what happened when I first tried my Misty, and I didn’t know any better at the time, so kept driving and probably burned up the left motor.

So…I decided to take the tracks off my Misty. It doesn’t get as good as traction, but at least I don’t have to worry about jamming and/or ruining a motor.

And I’m learning little bits about the hardware along the way, so that’s fun too!


Supercool! Glad it’s working now,


It seems my Misty has lost LED and locomotion functionality again. I have been a little more adventurous with her lately - driving from hardwood on to carpet and back. Maybe this has jiggled a connection loose?

The LEDs on the RT and MC boards seem to be working as indicated. Anything else I should check?

I’m also happy to drop her off at the office so you guys can run diagnostics, if that’s easier.


If you command the chest LED or driving from either Blockly or the API Client, nothing happens, correct? If that’s the case, I would suspect that the connection between the Dragonboard and RT Controller isn’t seated correctly, or has failed. Check that connection and let me know. If it looks good, you may need to bring your robot in for a bit of service.

1 Like

Aha! I took the 410 board off and saw the disconnected cable.

Plugged it back in and everything works again! Thanks for the help!


1 Like

You’re welcome! Were you taking your robot off some sweet jumps? :wink:

Yeah, I built a half pipe for her and am hoping she qualifies for the next Winter Olympics!