Robot Not a Dev? Buy Now
Not a Dev?

Misty Community Forum

Q: How do I connect to or use the Misty App with Misty?

A: Read how to use Misty’s companion app here.

attempted to connect through several phones w/ correct wifi password. Is there another way to connect or get the ip address? how else can we connect?

The IP address can be found by connecting Misty to your router via ethernet cable and using the windows portal. Let me know if you have any questions and I can walk you through the steps.

We don’t have immediate access to the router. Is there a reason that no phones will connect to misty?

What exactly is happening when you try to connect through the Companion App? And are you on a shared network or are you the admin of the network?

When we tap the app to misty, then select the wifi used for the phone and we get the error message “can’t connect to your misty” we retry with connect to a new misty. We have tried this with several phones and on the guest wifi as well. Thank you for helping us.

Just want to make sure, is bluetooth on the phone turned on and is the robot in close enough range to the phone when trying to make the connection?

Yes to both questions

Ok and are you on a shared network? In other words, are you on a network that requires additional credentials other than a password? For example, a network in a hotel or university.

It’s a shared network that requires a password only, no additional credentials.

Ok, have you tried power cycling the robot? Also, is the robot plugged in?

Yes and yes

And I also want to make sure that you have been waiting for Misty’s eyes to fully load before attempting to connect.

@Justin If you have any fixes or workarounds, please feel free to give any input.

We have followed the on-boarding as specified including waiting for the eyes to open before connecting

I have reached out to our App developer, @Justin, to see if he has any ideas as to what could be going on. Thank you for being patient as we work this out and I apologize for any inconvenience.

Thank you for your help, no worries take your time

@tortillas as I understand it, you have got to the page in the app with the list of wifi networks, you select a network, enter the correct password and after a few minutes are greeted with a “Can’t connect to your misty”, is this about right?

If this doesn’t seem to work you can hit the “Skip” button and go to the “My Misty” page, if your robot has an IP address and there is an error in the app it should still be listed there.

A couple of other things to check:

  1. Your phone needs to be on the WiFi network you’re trying to connect to
  2. Your network should use WEP or WPA authentication, enterprise networks (with additional credentials) and open networks are unsupported but we’re working on adding open networks.

our network is WPA2 password protected. We had gotten to the My Misty page when we hit skip but the ip is all zeros.