Robot Not a Dev? Buy Now
Not a Dev?

Misty Community Forum

Problems With Misty 2 Driving Forward

I just returned from the Austin Developer Week. After starting up at home Misty 2 has trouble driving forward but can drive backward with no problem. Forward drive either does not work or works intermittently. The problem occurs when using the phone app, command window, and using Hello_world program. How to debug this problem?

Hi @karlrenner,

Glad your robot has arrived, and sorry to hear about your driving troubles! We have a few suggestions you can try.

First, it’s helpful to know whether you’re driving Misty using the App, the driving controls in the Command Center, or some other method, so thanks for sharing that level of detail.

Second, Misty’s time-of-flight sensors – the sensors she uses to detect obstacles – can, depending on environmental circumstances, sometimes trigger Misty to react to obstacles that aren’t there. Misty is programmed by default to automatically ignore forward drive commands when she thinks there’s something closer than 0.15 meters in front of her, so if there’s something going on with your sensors, that could be the cause.

Here are some next steps:

  • Could you follow these instructions to get a diagnostic report and attach it in an email to our support team? This will help us understand what’s going on under the hood.
  • It may be worth a try to connect Misty to the Command Center and see what kind of time-of-flight readings you’re getting. With Misty connected, scroll to the bottom where it says “Sensor Data” and check the box next to each time-of-flight sensor. If you do this, see if any of the front sensors return a distance value of less than 0.15 meters, and if so, what the status code is.

Getting the diagnostic report and sensor data readings is a good next step for troubleshooting, and we can decide how to move forward from there. Additionally, there has already been some discussion around time-of-flights from developers who have had a similar issue to what you’ve described, and you may find some of it useful or interesting.

Hi Karl!

One other thing we tried when you were with us at Dev Week was to try turning off the edge hazards. Here is the curl script we used (Just run this script on your command line):

Keep in mind this will reset on every power cycle, so you’ll have to issue it on each startup.

Let us know if this helps!

-Chris

1 Like

Here is a snapshot of the time of flight sensor data which show problems with the Time of Flights sensors:
sensor%20data

I entered this curl script into the console of the diagnostic window and get a unexpected syntax error:
curl -X POST \ http://192.168.1.73/api/hazard/updatebasesettings
-d ‘{
“bumpSensorsEnabled”:[
{“sensorName”:“Bump_FrontRight”,“enabled”:true},
{“sensorName”:“Bump_FrontLeft”,“enabled”:true},
{“sensorName”:“Bump_RearRight”,“enabled”:true},
{“sensorName”:“Bump_RearLeft”,“enabled”:true}
],
“timeOfFlightThresholds”:[
{“sensorName”:“TOF_DownFrontRight”,“threshold”:0},
{“sensorName”:“TOF_DownFrontLeft”,“threshold”:0},
{“sensorName”:“TOF_DownBackRight”,“threshold”:0},
{“sensorName”:“TOF_DownBackLeft”,“threshold”:0},
{“sensorName”:“TOF_Right”,“threshold”:0.1},
{“sensorName”:“TOF_Left”,“threshold”:0.1},
{“sensorName”:“TOF_Center”,“threshold”:0.1},
{“sensorName”:“TOF_Back”,“threshold”:0.1}
]
}’

Did you try running the curl script from the web browser console? If so, try to run it from your Mac terminal (or command prompt, if you use Windows and have curl installed), instead.

And you can also update the hazards settings via a REST client like Postman. If you don’t already use Postman, you might consider downloading the free version for use with Misty – it can be a great way to get familiar with her REST API.

  1. Create a new POST request for the <robot-ip-address>/api/hazard/updatebasesettings endpoint.
  2. Under the Headers tab, set the Content-Type to application/json. Then, under the Body tab, select raw and paste the following JSON object:
{
    "bumpSensorsEnabled":[
        {"sensorName":"Bump_FrontRight","enabled":true},
        {"sensorName":"Bump_FrontLeft","enabled":true},
        {"sensorName":"Bump_RearRight","enabled":true},
        {"sensorName":"Bump_RearLeft","enabled":true}
    ],
    "timeOfFlightThresholds":[
        {"sensorName":"TOF_DownFrontRight","threshold":0},
        {"sensorName":"TOF_DownFrontLeft","threshold":0},
        {"sensorName":"TOF_DownBackRight","threshold":0},
        {"sensorName":"TOF_DownBackLeft","threshold":0},
        {"sensorName":"TOF_Right","threshold":0.1},
        {"sensorName":"TOF_Left","threshold":0.1},
        {"sensorName":"TOF_Center","threshold":0.1},
        {"sensorName":"TOF_Back","threshold":0.1}
    ]
}

Should look like this:

  1. Click Send

Let us know the results!

1 Like

Allison Sturm from Customer Support ask me to send the robot back for debug and send me a replacement robot. The time of flight sensor data seems to be wildly fluctuating and blocking the forward drive.

Regards,

Karl Renner

1 Like