Robot Not a Dev? Pre-order Now
Not a Dev?

OOB Experience notes


#1

Started up my new Misty I today. Here are some of my notes about my OOB experience.

  • disconnect between paper instructions printed in terms of battery & startup. Paper says to “plug power into port and then wall”. When I did that, the battery-charge level didn’t come on (all dark). So, I turned the robot on (at which point battery-charge level showed 7.03). Paper instructions say “if the number doesn’t go up, unplug and replug the adapter”, which I did. But the numbers still didn’t go up. After looking at the online docs, I realized it seemed like it was after boot, so I unplugged / replugged and it started to charge.
  • Paper docs did not discuss plugging in Occipital; figured that after re-reading the online version of startup.
  • In going through getting started, the sequence is very nice at the beginning. Good instructions. Then, at end of Getting Started section there’s no real sense of what to do next. I can see I can click on “Companion App”, but there’s no intro, for the OOB sequence that says “in order for you to work with Misty you’ll need to get it on Wifi, which you can do through the Companion app or [these instructions]”. Knowing enough about things, I know that after power up next step is to get WiFi on board via companion app, but as a noob I wouldn’t have known.
  • I didn’t have a signup screen in my Companion App startup - it just started up to “tap Misty to connect”. Probably due to the fact that I upgraded from a past version(?)
  • After tapping to connect and entering password for my WiFi network, it attempted connection for 30 seconds or so and then went to the Misty home screen. However, there was no IP address (0.0.0.0). In “My Misty” screen it shows the proper SSID for my home network, but it shows 0.0.0.0 IP address and Network Status as “unknown”. There are no instructions for the Companion App on what to do if WiFi is disconnected. At this point I’m stymied on how to proceed. (Companion App version 1.1.0 (1.1.103)
  • I decided to reboot robot, forget this Misty, restart app and retry connecting. Success.
  • Tried driving with companion app using joy stick (whilst on a block on table top). backwards and turning created motor action; forwards created tiny intermittent bursts. Then, I turned the robot (thinking the ToFs were sensing something) and got zero action. Then, turned them back towards me on the desk and they worked fine.
  • I opened up the API Explorer next (before doing a software update). Connected = Success (yeah!)
  • I used the “manual” drive buttons. I had to press the forward button twice to get any motor action, then the stop button twice. When I pressed backward button, same thing - had to do it twice. Then, stop button about 5 times before it would stop. In the console I had a bunch of POST timeouts.
  • Pressed “software update” in settings. No user feedback about what’s going on - no sense of whether the button was pressed successfully or not - but after a few seconds “No Software Update at this time”. Wasn’t sure how to check / where to check to make sure my robot had the latest software version. Where do I do that? I went to the Community and looked for “version” and saw the release notes for the 8/2/2018 release (yeah!) and read that. I saw that the Home Robot app version is supposed to 1.1.7.0 but, sadly, mine is 1.1.6.0 – which implies there should be an update for my robot but when I checked via the app it said “no updates”. What to do now? Saw that my MC, RT and Sensory Services are also out of date to that 8/2/2018 release note.
  • Looked at docs for API Explorer software update and followed instructions. Went to bottom of API Explorer and clicked on “check for updates”. No visual feedback and no messages. Wondered what to do – wondered whether I really had clicked the button (it changed color briefly). Pondered for 60 seconds and then tried again - pressed “Check Updates” button and this time in Console got “success” and small black window “updates available”. Pressed Perform System Updates and got message “system updates queued”. So, I’m feeling pretty good about myself at this point.
  • While the download is going, I figure I’ll create my first sound file for the skill I have in mind and upload it. I create the sound, convert it to .wav and save to my Desktop. I click the audio dotted-outline square on the API Explorer, it brings up the proper dialog box for me to select my WAV file. I choose accept and it shows me the file name. Then, when I click “Save To Robot”, I get a message that I must “check the checkbox” – but :disappointed: there’s no checkbox to check. I try a different file. Same result. I try again, this time dragging & dropping. Again, success on getting the file name into the box, but not check box. At this point, stymied - have to ask support.

I’m now into my project, so that’s the end of my onboarding experience.


#2

Thank you Tim for the feedbacks! @Donna I think it’s really important for you to see this! Great points to improve the documentations:) I will also put those feedbacks into the customer support field tracker which can be later escalated to engineering.


#3

One more question Tim, it sounds in slack that you have successfully uploaded the audio file onto the robot, is the “no checkbox to check” still a problem for you or it’s fixed?


#4

Still an issue on Safari - I was only able to upload on Chrome. (Minor bug if validated).


#5

Thanks again, @tenwall and @lucyz for the terrific details. I can let you know that as of last week we’ve changed the process on the paper docs, and I’ll be keeping them up to date. I’m noting the other doc issues Tim has reported and will start addressing them today.