Robot Not a Dev? Buy Now
Not a Dev?

Misty Community Forum

My Misty arrival - startup issue

My Misty arrived box was in good shape.

Removed bubble wrap, small box (power connector/USB-C)
Lifted Misty out of the box and removed remaining bubble wrap (it was well wrapped).

I plugged it in, and turned it on. Purple-ish light in front and red lights internally started
up. I could not get the side board to startup.

Upon further inspection I noticed the ribbon cable was not connected to the loose
board in the head that looks to have the ribbon cable connector. I think I need to remove the
head supports to plug that ribbon cable into the board with the connector and see if there
is a good way to make the board more ‘fixed in place’.

I thought I would as before doing this.Mysty-Ribbon-connector

If I have the battery plugged in when I power up:
1. Head goes up
2. Buzz of the motor continues
3. And it still does not turn the ‘side-board’ u820 carrier board. But when I press the On/Off on the board I see a single Green blink of the DS3 light

Do you have suggestions on:
1. What you would like me to do for the Ribbon cable (take off the head support)
- just go for it or use a toothless pliers to insert may work
2. Why the development board is not powering up and if the continual ‘hum’ is normal
- my guess is it is just powering the motor to keep the head upright. Versus a worm gear
or a screw type would not require constant power.

Thanks!
Mark

For the side board - when you turn on the robot, then press the ON/OFF button (S100 as labeled in your photo) does the GREEN (DS3) LED blink?

Hi Mark!

To answer your questions:

  1. I’m checking on this one, will get back to you here shortly on how to best to resolve that problem.

2a. With the development boards, we do not have a programmatic way of turning those on when you power up your Misty. Unfortunately, you’ll have to do exactly what you did and manually turn on the 820.

2b. You are correct, the hum is the motor keeping the head level.

You may be able to get the ribbon cable back in place without taking anything apart:

Ensure the black stubs at either end of the port (that the ribbon cable inserts into) are not pushed in. Then insert the ribbon cable and push both black stubs in. This locks the ribbon cable in firmly.

It only blinks once and is off after that. And I was not sure if it was related
to the ribbon cable not being connected.

Thanks I will try that first. I am good with ribbon cables, etc.
I do raspberry pi’s with cameras and taught a lot of kids basic level
soldering, electronics, robotics.

As long as it blinks once, you’re good to go!

@markwdalton

That ribbon cable needs to go in the CON2 connector. See attached images:

1 Like

I can write up instructions (of the Solarbotics flavor) with pictures every step.
(And separately do video if you want) once I have everything working.

It is plugged in and the ribbon cable holders are clamped and it is firm.

Powered up. Head up, lights in front on. u820 carrier board ‘On/Off’ pressed
with a single blink.

I do NOT see the:

  1. A blue LED on the left side (as you face Misty) of the Occipital navigation sensor should come on.
  2. No response from saying ‘Hello’
  1. Is the occipital sensor plugged in?
  2. Alas, the units with the developer boards do not have our microphone array integrated. The only way Misty will respond to ‘Hello’ is if you type it out in ‘Hello World’ using our API’s (https://docs.mistyrobotics.com/)

@markwdalton

Do you see this on the robot face?

Is the Occipital sensor plugged in like this?

Thanks that is better now the LCD face/eyes are up. The conn2 helped :slight_smile:

I was reading from:
https://docs.mistyrobotics.com/onboarding/getting-started/powering-up-down/

Mark

@markwdalton gotcha! Thanks for the clarification :slight_smile:

Thank you for the assistance. I wrote down the steps with pictures and you are free to use/modify/delete whatever you want of course. But I was thinking of something like this
when it arrives to save on questions. (But I cannot upload a word/pdf doc here).

1 Like

Hi Mark,

I just sent you a direct email (from here on the community site) that contains my actual email address. I’m so sorry for your difficulties getting started, and I’d be delighted to see whatever notes on your experience you care to share.

Many thanks,
Donna

Hi Mark,

Just wanted to let you know that I got your notes from Daria, so no need to send again.

Indeed, as you note, the “Say Hello” was not meant to be literal, so really didn’t belong with the instructions. I’ve removed that from the docs. If interested, you should be able to see that and other changes live on the doc site later today.

Thank you again for your patience and persistence. We deeply appreciate the feedback!

It was no problem. I think that is sort of the point about having this program to work out the issues to make it easier for others.

I was thinking I did not put in the step to ‘add the Camera’ and attach it to that document, which could also be added.

I just thought the ‘Say Hello’ was already there :slight_smile: sigh… I assumed to much. (With having devices around the home and raspberry Pi’s with this. We should get that setup soon :slight_smile: I will look at that when I get the other issues worked out.

Here are my notes, but I am still working on, and will ask for help once I read docs and others efforts. (It is good for me to work at it a bit first, I learn more).

My notes so far:

2018-04-25

  • received Misty
  • Unboxed, attached battery, optical sensor, camera, power cord
  • Ran into a problem:
    - Second board in head (connector1, Connector2) with the Ribbon Cable
    - The board is loose/floating
    - My guess is in the shipping the board shifted and the ribbon cable came loose
    - Tabs were still in locked position
    - I sought advice from the Misty Forums, they explained to go ahead and
    attach. And informed me it goes to the middle connector (Conn2 with picture).
    - Then I could see the screen/face power up … snapdragon -> eyes

Other notes, very minor but may help clarify:
* The u820 carrie board, when powered up the green light just blinks once for
a fraction of a second.
* The “blue LED” on the left as your facing it, is really just the USB->USB-C
connector lights, you need to look from the left side of the head
(the side where the u820 carrier board). (When you say ‘blue LED’ I would
expect a exposed LED, versus the internal to the USB connector).

  • Issues connecting to bluetooth directly complained about a PIN
    - I do not know the PIN
    - CompanionApp was able to connect (probably it has the PIN included)
    Companion app could drive the wheels.
    - Failed multiple times to connect to WiFi:
    * 2.4 GHz - WPA2/WPA Mixed Personal - longish password with special characters SSID broadcasted
    * 5Ghz (same as above) but not expected to work
    * 2.4 Ghz - guest Wifi, no security, Password simple (word with a number)
    (Each time I moved my phone to that network then tried to have Misty connect).

  • Attempted to connect to the IP address for Misty (in my gues 192.168.1.195)
    http://192.168.1.195:8080/
    - It requested a login/password, the video said for manual upgrade it would be in a document
    (I need to find that document :slight_smile: )

  • Documented with some of the pictures and simple steps for setup.

2018-04-25

  • Tested the Mapping, using the companionApp
  • Drove about 8 feet and would no longer move
  • I picked it up and placed it back on the box on my desk
    Driving still did not work. (No friction on motors)
  • I let it cool/sit for a few hours, and reconnected with
    the companion app and the drive is working again.
2 Likes