Home Community Blog Buy Now
Blog

Misty Community Forum

Misty updates every time i reboot, not responding to movements

Hi,

Every time i reboot misty, she does a firmware update on motors, etc.

I have not rebooted in about a week, this just started happening last night when i turned it off and on again.
Also, having problems getting misty to change yaw, pitch from command center.

Wes

Also, not repsonding to any movement commands.

@wlaubach64 sorry to hear that, we’ll work with you to get this resolved. I’m guessing you already have but I just wanted to check - did you try doing a targetted update on just the MC/RT using the command center?

Hi, yes I tried that a few times , did not work.

Hi Wes,

Could you share the fully expanded Device-Info data printed on the console in command center.
That will have the exact MC & RT Firmware version numbers on your robot… This should give us some direction for debugging faster.

Thanks,
CP [• •]

Hi,

Here it is:

  1. {androidHardwareId: “a54a0d8f2e586105”, androidOSVersion: “OpenQ820_O_v4.1-OPM1.171019.026-scripts1.0.1-patch1.0.5”, batteryLevel: {…}, currentNetworkId: 0, currentPreSharedKey: “”, …}

  2. androidHardwareId: “a54a0d8f2e586105”

  3. androidOSVersion: “OpenQ820_O_v4.1-OPM1.171019.026-scripts1.0.1-patch1.0.5”

  4. batteryLevel: {chargePercent: 0.99, created: “2020-10-20T17:15:37.7823651Z”, current: -0.37, healthPercent: 0.26, isCharging: false, …}

  5. currentNetworkId: 0

  6. currentPreSharedKey: “”

  7. currentProfileName: “EllaNetwork”

  8. hardwareInfo: {rtcBoard: {…}, mcBoard: {…}}

  9. ipAddress: “192.168.1.122”

  10. macAddress: “00:d0:ca:00:5c:26”

  11. networkConnectivity: “InternetAccess”

  12. outputCapabilities: {/Robot/HardwareController/: “v1wxLR”, messageStream: “DypFfI”, pruControl: “kbtSqJ”, locomotion: “VyExVx”, user2: “XXMSQe”, …}

  13. robotId: “00A0C6AB9030-00800F117000~a54a0d8f2e586105~294941-540160565~1835038-540488760~x”

  14. robotVersion: “1.19.1.10694”

  15. sensorCapabilities: {actuator_LeftArm: “ala”, bump_FrontLeft: “bfl”, currentSensor_HeadRoll: “cshr”, /Sensors/HardwareInfo/McBoard: “McBoard”, currentSensor_LeftArm: “csla”, …}

  16. sensoryServiceAppVersion: “1.19.1”

  17. serialNumber: “20194803958”

  18. sku: “060-000001”

  19. structureCoreDeviceInfo: {structureCoreDriverVersion: null, structureCoreFirmwareVersion: null, structureCoreSerialNumber: null}

  20. windowsOSVersion: “10.0.17763.253”

  21. proto: Object

Sorry forgot to expand the hardwareinfo:

  1. mcBoard:

  2. boardId: “1835038-540488760”

  3. firmware: “1.19.1.198”

  4. hardware: “74.0”

  5. proto: Object

  6. rtcBoard:

  7. boardId: “294941-540160565”

  8. firmware: “1.19.1.198”

  9. hardware: “75.0”

After more troubleshooting on my own, it only reloads everything if Misty is started off the charger.

When on the charger, the reboot works fine. But after moving around becomes unresponisve.

What’s the battery level when this is happening?

Hi,

I just took if off the charger. Rebooted it, and it did not do the update. I then tried driving it thru command center , was unresponsive. Manually updated the Motor firmware, was able to drive for about 2 seconds, then froze. Not responsive to movements. Now doing the update when i reboot off charger everytime.

here is the battery level when it froze.

  1. batteryLevel:

  2. chargePercent: 0.99

  3. created: “2020-10-21T11:38:48.2015321Z”

  4. current: -0.32

  5. healthPercent: 0.27

  6. isCharging: false

  7. sensorId: “charge”

  8. state: “Discharging”

  9. temperature: 0

  10. trained: true

  11. voltage: 8.293

Do I need to return Misty? It shoukl still be under warranty?

Here what is now happenning in the console when i click connect: Did not click on anything else, just the connect button

commandcenter.js:3070 Connected successfully.
lightSocket.js:86 Opened socket
lightSocket.js:26 Subscribing to ActuatorPosition as ActuatorPosition_ahp316
lightSocket.js:26 Subscribing to ActuatorPosition as ActuatorPosition_ahr206
lightSocket.js:26 Subscribing to ActuatorPosition as ActuatorPosition_ahy305
lightSocket.js:26 Subscribing to ActuatorPosition as ActuatorPosition_ala757
lightSocket.js:26 Subscribing to ActuatorPosition as ActuatorPosition_ara701
lightSocket.js:62 Unsubscribing from ActuatorPosition_ara701
lightSocket.js:62 Unsubscribing from ActuatorPosition_ala757
lightSocket.js:62 Unsubscribing from ActuatorPosition_ahp316
lightSocket.js:62 Unsubscribing from ActuatorPosition_ahr206

Send your logs to support email. Sounds like something went awry with the firmware update (which controls all motors etc which is why you’re having issues moving robot).

Hi,

I installed ADB as stated in this post:

when I try to connect to Misty , i get the following error:

A connection attempt failed, did not respond after a period of time.

Any ideas?

Wes

Are you trying to connect to the robot via a hard wire (ethernet) or WiFi? There was a patch 9 months ago that had the default behavior of turning off ADB over WiFi (2020.01.07: Misty II Android Patch for Improved SLAM Performance - Releases - Misty Community Forum).

In parallel to debugging your Misty, you are welcome to use 1 of the Misty robots that I have remotely: https://rerobots.net/sandbox

You don’t need adb logs for this. Just send the logs from command center (Download Log Files button).

What is the support email I can send the log, the support link on website does not allow me to attach file…

Wes

Found it…I sent the log.
Wes

Hi, is there any word on this yet?