Robot Not a Dev? Buy Now
Not a Dev?

Misty Community Forum

Misty II reporting different Network issue

Hi,

Misty 2 claims that my phone and the Robot are on different networks and they are not.

Regards,

Chris

Thanks Chris. For reporting this we really appreciate it and welcome to the community forum!

A few quick questions:

  1. Does this affect your ability to control Misty using the Companion Phone app?
  2. Does this still occur after you close and restart the phone app?

Apparently I’m limited to 1 screenshot in a post? Also, the mobile version of the site doesn’t show the option to upload screenshots to your tickets :slight_smile: — <-- Can this limit be removed? See attached.
It does let me move Misty II, but it does not show me any of Misty’s info…

Thanks @christopherwking we’ll look into removing that limit of attaching more than 1 picture.

Does this still happen when you turn on and off the phone and reconnect to Misty?

Also what type of phone is it? And what OS?

Hi,

IPhone XS Max. I am going to test something when back home. It’s on an Orbi which might be handling 5Ghz and 2.4Ghz bands on a single SSID.

Chris

Awesome! Thanks @christopherwking keep us posted!

We’ll add these items to the Meta Category in the forums to discuss.

In case it helps, I noticed this too and mentioned it in a bigger list of feedback I provided at General feedback for Misty II App and Overview pages · Issue #83 · MistyCommunity/Documentation · GitHub - the response there was:

When I connect Misty II to the network I am getting a dialog box that says:
Wifi Network Mismatch
Your phone and Misty are currently on different wifi networks. Some app functions won’t be available. Would you like to change Misty’s wifi network?

The un-helpfulness of this alert is a known issue with the app :slightly_frowning_face: It’s leftover from a time when the app used more Wi-Fi functionality (whereas now, most functionality between the robot and the app happens via bluetooth). We’re looking at ways to improve the UX here, and should have an update for the app soon.

1 Like

Thanks @mbd and @christopherwking for reporting this issue. I’m concerned that this happens on certain routers/configurations where the phone and Misty are indeed on the same network but reporting it differently thus prohibiting some functionality on the phone application.

@christopherwking did this issue still happen when you went back home?

@mbd I’m assuming you left the hotel and don’t see this issue anymore but I’d love to diagnose and figure it out when you see the same issue. Feel free to report here if you see the same issue.

BTW, some networks (usually public, guest) do not allow peer to peer connections for safety reasons. This could be what is triggering this error.

1 Like

I’ll still be at the hotel for another couple of nights, happy to try some diagnostics or tests. Let me know what I can do.

(Edit: did a port scan, adding more info)

Confirming that:

  • I still get the mismatch error
  • both devices are on the same subnet
  • I can ping the Misty from my phone.
  • (and that it’s a secure PSK password protected wifi network without a captive portal)

Out of curiosity I note that the bot has non encrypted ports open. Is there any plan to offer a token or other layer of authentication to the bot, and/or implement encrypted communication?

And, is the ssh port accessible for users?

Good questions, we’ll check with those closer to these issues and follow up early in the week :slight_smile:

@mbd, following up on this:

While we have no plans for this at the time, I would strongly encourage you to post this request (and how you’d use it in your development) to the Wishlist category, so that other Misty developers can contribute and vote on it. Our product team reviews this category to prioritize new features and keep Misty’s roadmap in sync with what developers need.

And, is the ssh port accessible for users?

The ssh port for the Android device (that’s the IP address you typically use when using the Command Center or Misty’s REST API) may be accessible, but if it is, that access isn’t officially supported or documented. If you’re able to access it, I’m not sure there’s very much you can do with it at the time. That may change in the future – especially if we see a lot of interest around this in the Wishlist category!

2 Likes

I’m back home in Australia with Misty now, and have had some time to do some setup at home. I’m having some more strange network issues…

  • I’m still getting Wifi Network Mismatch warnings in the iOS app, despite Misty being on the same network at home as my devices. I’ve checked and have the following:

    • iPad - 192.168.1.12 - 11ac(5Ghz)
    • iPhone - 192.168.1.34 - 11ac(5Ghz)
    • MacBook Pro - 192.168.1.41 - 11ac(5Ghz)
    • Misty - 192.168.1.93 - 11ac(5Ghz)

The iPad and iPhone report the network mismatch, and additionally the laptop doesn’t seem to be able to connect reliably when I go to Misty Robotics / SDK /Command Center and try and connect (tried Firefox, Chrome and Brave browsers). I’ve also tried restarting Misty, the browsers, the iOS apps and all the network devices as well.

Any suggestions on what I can do to troubleshoot this? A port scan from the laptop to Misty gives:

Port Scanning host: 192.168.1.93

	 Open TCP Port: 	22     		ssh
	 Open TCP Port: 	80     		http
	 Open TCP Port: 	445    		microsoft-ds
	 Open TCP Port: 	5555   		personal-agent
	 Open TCP Port: 	8080   		http-alt

I’m happy to do a factory restore/reset of Misty if that might help, but I’ve not yet found information on how one might do that.

Edit: Just tried the API Explorer at Misty Robotics / SDK / API Explorer and that connects to Misty just fine. :confused: - I went through the system section and removed all saved wifi networks and tried again (adding Misty to the wifi network I use at home). Still fine with the API Explorer, but not the Command Center.

Hi @mbd! The API explorer and Command Center use the same JavaScript functionality to connect and call into the robot, so its strange that one would work and the other fail. Are there any clues in the debug console within the browser? My best guess is that the websocket connection isn’t being established which could lead to other scripts on the page failing, but that’s just a guess :slight_smile:

1 Like

Test the ping to the Misty also. I and another person were both seeing
issues for Misty II with pings, both packet loss and with extremely slow ping times
for a local network.

See: Long Ping Times for Misty

The ping from Misty both android and MS Windows out to linux/macOS machines seemed okay. But only Misty II (Windows) had a issue being pinged and returning the packets correctly and fast.

Scott had misty connect to his Phone (hot spot) and it did better and no packet loss.

Mark

I let the robot sit its corner overnight charging and went to sleep. This morning, it seems to be connecting okay, so I wonder if it might have been battery related (though why the same functionality would have worked for API Explorer but not Command Center, I don’t know).

I did do some ping tests, and it doesn’t seem to have excessively long responses or packet loss:

Misty:

20 packets transmitted, 20 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 23.238/67.033/116.233/30.574 ms
2 Likes