Robot Not a Dev? Pre-order Now
Not a Dev?

Misty Community Forum

Misty II arrival - Only two main issues (power and disconnects)

My Misty II arrived, I properly took out of the box (tisk…tisk… Ian :smile: ). It worked immediately. I am guessing no voice commands default, I used the phone app Misty Companion, to connect to WiFi and drive around.

The good:
1. Came safe and in great working order.
2. I loved the case! Nice add-on and keeps it safe to show to others.
3. I like the idea of the wireless charger (I just need to figure out my problem
to see if it is related). But I am also wondering if it is ‘bleeding power’ somewhere.
4. The look is still great.
5. Nice voicing on the command-center… close to words but the non-word makes it more ‘cute’ somehow (R2D2 vs C3PO)
6. Driving seemed pretty smooth, there were some delayed responses at times.
7. Head and arm movements worked and stayed for me.
8. Did some drive and mapping, but have not looked at the mapping yet.
9. The Upgrade seemed to go fine.

Brief summary of issues:

  1. Minor: the Android phone app Misty Companion
    * Battery always shows empty: --.-%
  2. Center of balance/clearance is still a bit of a issue.
  3. Battery did not seem to charge very well. (0.3 - 0.8 from web but loses power even while idle on charger).
    29%20PM
    My Misty II arrived and it worked for about 10 minutes. It flipped on its back going into the kitchen (perhaps a 1 inch rise, but it had a carpet over it so it was smoother). I picked it up and kit did keep going and then it ran out of power (I was assuming) and just shut off.

(all references to charger are the wireless)
I did disconnect, powered off/on Misty then plugged in the wireless charger. On the web (sdk/Command-center) it got up to 0.44 and today up to 0.5, but just sitting on the charger it lowered to 0.4 while sitting on the charger (not moving but powered on). Overnight powered off, it got up to 0.8. (I am assuming that is 80%). Also with power on, I did try putting the head and arms down, and did the shutdown all motors but still only got to 0.4.
This afternoon after a little use, and while it was sitting on the charger it just powered off.

I have to figure out the new ssh login/password (I did not find that yet, and I will get adb setup and use that again).

Mark thank you again for posting to the forum and reporting this issue.
Also, thank you so much for all the feedback on the design and looks. We love reading these comments.

It does indeed seem like you have a charging issue, thank you for your patience and help with diagnosing this.

A couple of questions :

  • When sitting on the charger do you see this red light when you take off the rear “pants”?

  • Is it safe to assume that these charging issues do not occur when you plug the AC adapter Misty and not use the wireless charger? or do they occur while plugged in too?

  • The ssh login/password that you were referring to is that for you to log in to our Windows IOT administrative portal or for you to adb into the Android OS?

  • Could you describe more on it flipping over on it’s back and what might have caused that? Might you have a video you can show us? I’m also curious about the balance/clearance issues and how we might better solve that.

  • Yes there are no voice commands by default and you might already know this but we do have an inbuilt wake word you can experiment within javascript.

Thank you for the quick reply. No rush, I may order a AC adapter.

  1. This is only on the wireless that I know. I do not have a AC Adapter, that is optional
    apparently. And I did not yet look to see if I have one that would work in one of my
    bins.

    • Note: when it powers off on the charger, it has no lights, and will not start powering up again until, I power it off, leave it for 10 seconds and power it back on. And from the web/command-center it states now after overnight is is ‘0’ battery.
  2. I would like to know any and all login/password on the devices. I will do a security
    audit on the machine, and perhaps invite my friend to also.
    - direct ssh to windows
    - adb to the Android

  3. Could you also talk more about it flipping over on it’s back? Might you have a video you can show us?
    - I can try it again once I get a charge, it powered off on the charger again last night.
    - I would have to film it to remember if it ‘jerked’, but I know it did not make it the first
    time so I had to backup and go. If there was more weight in the ‘track/motor’ section.
    (or if the track/wheel/arms where a separate part [… hint …hint …] I could swap it out or add weight, strength/framework)

  4. Yes, I saw the wake word addition, and we had some on Misty I, python wrapper.
    For other issues like privacy if say a child was using it for journaling or therapy, I would like to see it not go to the ‘cloud’ unless it is a ‘search for’ or when ‘journaling off’.
    That is why I have been working on this local to a Raspberry Pi, and on my linux notebook. Local speech-to-text and text-to-speech.

Thank you again! Mark

Hey Mark. So great of you to be continuing forward with us!

One quick note about voice and privacy. The content of Misty’s audio steam DOES NOT go to the cloud unless you, the developer, ship it off board (for storage, to Amazon/Google/Microsoft, etc…). Same goes for camera(s) data stream and all other sensor streams.

Hopefully that will help you rest easier about privacy, especially when children are near.

I understand the general audio stream does not. But if someone uses
Alexa, Google, or other it does to ‘the cloud’, is translated and used by Google/Amazon/Microsoft and sent back. My point is a full Speech-to-text/text-to-speech while offline. Wakewords are normally local, and it is easy enough with a small vocabulary and in a single language.

I love Google’s speech-to-text/text-to-speech (I have booth Google homes and Alexa/Eufy), and it handles multiple languages, etc. I think there is room for both.

On the power there was no lights/leds on after the unit powered off even on the charger.
I did try downloading the logs previously (via command-center) and that did not work, which was part of the reason I wanted the login/passwords.

Just now it did work to download the logs. Also currently it is charging, green lights in back.
The logs are reverse ordered (I would think append is more efficient). but it would not let me upload.

I see it clear text logs my WiFi Password, that should not be logged. And if it is stored in Misty’s configs, should be at least encrypted.

For Battery states, here is a summary of the number of times for each state just removing the timestamps:

mbp-mwd:MistyII mwd$ grep "Invalid battery state" mistylog.txt | cut -f2,3,4,5,6 -d"|" | sort | uniq -c
 132 DBG|20193502680|3|BatteryChargeSensor|Invalid battery state received 21. 
 289 DBG|20193502680|6|BatteryChargeSensor|Invalid battery state received 21. 
2353 DBG|20193502680|6|BatteryChargeSensor|Invalid battery state received 53. 
 246 DBG|20193502680|7|BatteryChargeSensor|Invalid battery state received 21. 
2409 DBG|20193502680|7|BatteryChargeSensor|Invalid battery state received 53. 
 289 DBG|20193502680|8|BatteryChargeSensor|Invalid battery state received 21. 
 491 DBG|20193502680|8|BatteryChargeSensor|Invalid battery state received 53.

I hope that helps, I am not sure what the states are yet.

Thanks @markwdalton we’ll get back to you on the power issue. But I wanted to answer some of your other questions/feedback first.

To adb into Android requires no password. For Windows it should be at the bottom of your robot.

The arms are easily removable using a screwdriver. It would be interesting to see whether you could 3D print something and then add more weight there to make it balance better.

Thanks for all your awesome feedback and questions!

Yes, I know the arms come off. But the base does not, so I would
on my MistyI likely disconnect the wheel motors (leaving the structure intact)
and build a frame.

The arms to lift 50-150 pounds, need a base/wheels/tracks/legs strong enough
and the frame that hold/motorize the arms. Think of Misty as the person, and
what I want is to build a simple Mech suit for it, but one that we can swap between
types of track-wheel-legs-?? and arm styles depending on task, but also adjust the
height. (Tasks like changing your oil, helping on a farm, pick up a bale of hay or feed
and carry it to the next place). So the locomotion base needs its own controller and power,
I prefer a RaspberryPi and just have a couple APIs [simple forward/backward/left/right * velocity]

Mark

One other issue showed up. The Wireless has gone away twice,
and the Misty II is still on/powered up. The previous time, it did
recover after I rebooted Misty II (this morning) and then there was
a update, which did complete successfully.

I will not reboot yet, I will do more investigation. It is not just
control-center port, the IP address is not pingable, so the driver
on the OS or the hardware is down. It is still powered on, greenlight
on the back, and still on the charger and it looks like it is charging
and fan is running. I may try directly connecting to it via ethernet
(or other suggestions).

FYI: I do use tmate on my Linux machine if you want a remote
console. I could setup a VPN or make a VNC or virtual machine
available.

Interesting, the Misty II IP address just started responding again
It seems to now be missing about 20% of the packets sent currently,
previously 100%. And the time is longer than it should be

mbp-mwd:Misty mwd$ ping -c 10 192.168.1.151
PING 192.168.1.151 (192.168.1.151): 56 data bytes
64 bytes from 192.168.1.151: icmp_seq=0 ttl=64 time=323.812 ms
64 bytes from 192.168.1.151: icmp_seq=1 ttl=64 time=225.624 ms
Request timeout for icmp_seq 2
64 bytes from 192.168.1.151: icmp_seq=3 ttl=64 time=257.826 ms
64 bytes from 192.168.1.151: icmp_seq=4 ttl=64 time=283.210 ms
64 bytes from 192.168.1.151: icmp_seq=5 ttl=64 time=508.130 ms
64 bytes from 192.168.1.151: icmp_seq=6 ttl=64 time=126.587 ms
64 bytes from 192.168.1.151: icmp_seq=7 ttl=64 time=252.631 ms
Request timeout for icmp_seq 8
64 bytes from 192.168.1.151: icmp_seq=9 ttl=64 time=285.369 ms
--- 192.168.1.151 ping statistics ---
10 packets transmitted, 8 packets received, 20.0% packet loss
round-trip min/avg/max/stddev = 126.587/282.899/508.130/101.037 ms

My roku or linux box respond in 5 to 26ms for the same packet size and
no packet loss on the same network (all over wireless).

Mark

Hi Mark, Has Misty dropped any API commands? Or are you exclusively using ping?

Mark, I’m curious about those ping times. Generally, I don’t expect packet loss, but more than that, those ping times are really high. When I ping my robot here, I’m seeing ping times from 5 to 80ms, though our network isn’t exactly designed around performance. I’d be interested in knowing what was happening on your 820 when the robot gets into that state, specifically in the way of knowing which processes are running, and the output of logcat.

1 Like

The only issue is I cannot login at those times. This was around the time it lost its connection. My guess is the is the Microsoft side is issues it was powered at that time.

That’s the root of where I’m going. If you’re pinging the IP address, that is hitting the Android instance. That instance hosts the wifi connection, and thus anything connected would appear as intermittent or completely down.

I see a AC adapter is being sent. I charged it over night while off. And it was at 0.77
this morning. It is still slow. It is between 116ms to 405ms ping times, versus 1.7 to 8.64ms
on to a android phone, 2ms - 5ms to a Apple Notebook all on the same wireless network.

I will see if I can run Misty II over that carpet and bump between my living room/kitchen after my meeting (that starts about now … ) :smile:

Mark

@markwdalton I think we might have isolated your charging issue: there is a soon to be resolved issue with our base station cutting power after 4 hours

If you encounter the robot not charging, you can try 2 things:

  1. Make sure the robot is aligned on the base station (there are arrows near the robot’s treads that correspond to similar arrows on the base station)
  2. Try lifting the robot off the base station for 5-10 seconds to reset the auto power off.

If your issues persist, please let us know!

Great! I will try that the next time. It repeats easily if I have Misty II powered on
and charging. (otherwise I would not know). But I have noticed removing it and
placing it back on does start charging again.

I do have it aligned each time, I hand adjust it to the arrows.

1 Like

I would guess it looses API commands (it is hard to know).

  1. API does disconnect and will not connect (if ping is not there, API will not work).
  2. API does not always respond to commands, it would highlight the direction button
    but nothing happens, I try stop, then try again, eventually it works. The head movement seems to work consistently, but I place the location, then push the ‘Set’ button.

Mark

For the ‘flipping’ and the center of gravity. I have not been able to repeat that (which is probably good).

1. It was stopping when it got close to the 'bump' area
2. I put a small book 'Frog on a Log' :smile: under the carpet to make it more of ramp.
3. Then it made it over, but you can see it tips.. I did need some speed to get over.

Video and size picture attached. Apparently videos are not allowed to upload, I put it on youtube (just a short clip).

https://youtu.be/gitvnw6TArI

And so you can see the height.

Thanks Mark, we got the videos.

One thing to note is we specced Misty to only be able to drive over 0.79in (2cm) obstacles. A 1in. obstacle should be recognized by the Time-of-Flight sensors, but it looks like the finish and angle of the wood might be allowing Misty to think it’s not as tall as it actually is. I’m curious, if you place misty ~12in away from the lip and subscribe the Time Of Flight web sockets, what do you see?

It is charging currently but it is 0.75 inches for the entire height.
I used the book and the carpet so it would be a ramp (smoother)
and on the other side it is about 0.6 inches, as the tiles come up
higher.

It made it over, but the first time it did not and it flipped, the 0.75
(without the little book) and on the carpet as the ramp was too
high for its center of gravity.

It is not a ‘problem’ just a FYI/observation, but also why I want to
be able to change out the locomotion with frame and arms, just have
misty as the ‘brain’/interface. (depending on the purpose, since I would
like more general purpose which requires carrying weight, seeing down from around 5 feet [like look for keys], arms that can pickup which requires stronger frame and locomotion [larger wheel clearance/tracks/legs] think at least 50 lbs).

Mark