Robot Not a Dev? Buy Now
Not a Dev?

Misty Community Forum

Misty has trouble moving forward

My Misty has trouble moving forward. It moves just a tad and then stops. It moves back without any issue. This is true for both hardwood and a yoga mat (not reflective). Any thoughts?

System Update
Robot Version: 1.5.3.9838
Sensory Services Version: 1.5.3
Windows OS Version: 10.0.17763.253

The time of flight data may be the issue here – I see signal fail on the 3 front sensors. The back sensor data seems accurate. Any idea how to fix the issue?

sanjay

Thanks for this note, @guptahome100 and providing more info. Can you do a quick test and remove the front two bumpers and see if Misty moves better after that? The beginning of this video shows how if you aren’t sure.

Hey @guptahome100 just as a quick FYI, the “signal fail” notification just means it isn’t getting enough “pings” back on those sensors, basically meaning there is nothing in front of it. “Signal Fail” and “Sigma Fail” will both be things you’ll see when moving around in open areas. Very common, and will NOT be causing the problem of not driving forward.

If Ben’s suggestion doesn’t work there are a couple other things we can try. Keep us updated.

Tried that… no change in behavior though. It does seem to me that the time of flight sensor data is not accurate. BTW – Can I attach a screen shot here?

Yup - try the upload image icon in the editor 37
If you don’t see that it may be that your permissions aren’t there yet.

Which signal fail code are you seeing?

I just tried it again – Moves back but not forward – not even a mm. Here is the TOF data.

not sure if this helps… I see a blinking orange/yellow light on Misty’s right side. The LED on the left is green

@guptahome100 Can you give a description of the setup? I.E. is she pointed into an open space toward the front? What happens if you point her toward a wall or object, about 100 mm in front of her?

If you power cycle her do these values persist?

The amber LED blinking at 1 Hz is what we call her RT “heartbeat”. It means the board collecting data from the main sensors is, at least, running correctly.

I have tried this in two different rooms – a large room 18x18ft and another 12x12 room with polished hardwood floor and a blue yoga mat. Power cycled as well. Sometimes, I can get Misty to move a little and then it stops with a jerk… Other times, it does not move at all. It moves backwards in all cases. The sideways motion is hit or miss… Here are snapshhots of the TOF data when 6in or so from a light wall… The data seems to be toggling between two values. Here are both.

(the second one comes next – I guess I dont have permission to send two files)

and the other one…

@guptahome100 Could you follow these instructions to get a diagnostic report and attach it in an email to our support team? It will hopefully give us a bit more information about what is happening. I can tell you from the images you sent it seems the front right range is having difficulty staying active, and that could be causing your issue. The logs may give us some better insight.

@guptahome100 I’d also like you to try turning the hazards off. This should at least let you drive around, and will also help us understand if this is the problem.

To do that, grab the following script and run it in your mac terminal or windows command prompt (requires curl installed).

gist.github.com

Turn off Hazards for Misty II · GitHub

gistfile1.txt
curl -X POST \
  http://IPADDRESS/api/hazard/updatebasesettings \
  -d '{
    "bumpSensorsEnabled":[
        {"sensorName":"Bump_FrontRight","enabled":true},
        {"sensorName":"Bump_FrontLeft","enabled":true},
        {"sensorName":"Bump_RearRight","enabled":true},
        {"sensorName":"Bump_RearLeft","enabled":true}
    ],
    "timeOfFlightThresholds":[

This file has been truncated. show original

Note that you need to change the range hazards from 0.1 to 0 on all 4 range sensors in that script.

Alternatively you can run the command through a REST client (I use postman). Details below:

  1. Create a new POST request for the <robot-ip-address>/api/hazard/updatebasesettings endpoint.
  2. Under the Headers tab, set the Content-Type to application/json . Then, under the Body tab, select raw and paste the following JSON object:
{
    "bumpSensorsEnabled":[
        {"sensorName":"Bump_FrontRight","enabled":true},
        {"sensorName":"Bump_FrontLeft","enabled":true},
        {"sensorName":"Bump_RearRight","enabled":true},
        {"sensorName":"Bump_RearLeft","enabled":true}
    ],
    "timeOfFlightThresholds":[
        {"sensorName":"TOF_DownFrontRight","threshold":0},
        {"sensorName":"TOF_DownFrontLeft","threshold":0},
        {"sensorName":"TOF_DownBackRight","threshold":0},
        {"sensorName":"TOF_DownBackLeft","threshold":0},
        {"sensorName":"TOF_Right","threshold":0},
        {"sensorName":"TOF_Left","threshold":0},
        {"sensorName":"TOF_Center","threshold":0},
        {"sensorName":"TOF_Back","threshold":0}
    ]
}

Should look like this:

  1. Click Send

This should let you drive around, but note that she will bump into things, and especially important she will drive off tables or stairs. So with this you should only drive her around on the floor.

Please give that a shot and lets see what happens. If that works I’ll have you enable all the hazards except the front right range sensor to verify it is the one causing the problem.

Thanks for your patience @guptahome100!

1 Like

I have a feeling that the front sensor is acting up – the data does not seem to change with how far it is from the wall. I have a diagnostic file, but not sure how to attach it – maybe I am missing permissions.

Just sent it to the support email from email address – sanjay.gupta@airfuel.org

This one will have to wait until the morning… Need to go now.

Ok, so I turned off the hazards and it does move around now. So we have a workaround for the time being. Thanks Steven.

Will be good to resolve the underlying issue though. Happy to debug together in the afternoon (I am on the east coast).
sanjay

Steven,
Here is a silly request… I was able to use the terminal on OSX to update the settings. However, when I used postman, I get the following…

{
    "error": "'/hazard/updatebasesettings%20endpoint' command not found for post request",
    "status": "Failed"
}

Any idea what I could be doing wrong? I replaced the robot-IP-address to the actual IP number.

@guptahome100 glad to hear the workaround worked. I’ll check the logs you sent last night once our support team shows up and I can get the logs from them.

As for postman…make sure that when you paste the text into the body field, you have “raw” selected, as well as “JSON”. I think it defaults to something different, and I vaguely recall seeing that as an issue before. If selecting those doesn’t work then I’ll ping someone here more familiar with postman to assist.