Robot Not a Dev? Buy Now
Not a Dev?

Misty Community Forum

Misty Died after about 30 minutes

My Misty arrived tonight and everything seemed to be in order. I had an initial issue with wifi that I was able to resolve.

  1. Wifi configures but displays an error message

Then things took a turn for the worse. I will try to be as detailed as possible for troubleshooting. I was able to drive misty around, play sounds, change faces, etc.

  • Misty was noisy at first, there was an audible buzz coming from the robot.
  • Her head just lost control and fell down in the tilted position and there was nothing I could do to bring it back up.
  • Driving was still operational at this point but I rebooted the robot and then everything motorized stopped working.
  • At this point I was still able to access the API console, blockly, etc.
  • I tried the steps in the new firmware update - no change.
  • It was then that I noticed that Misty was no longer making the audible noise and even changing faces or playing sounds stopped working.

I can still access the api console via ip address and I can still connect to Misty via bluetooth, but nothing works.

Will try again tomorrow if anyone has any ideas.

Is the front LED still working?

Yes, Please try to change LED via API or Blockly. If it doesn’t work it could be that some connectors got loose…

It could be a Time of Flight sensor that tripped the I2C bus. Try disconnecting the sensor in the front from the RT board. Can someone provide a picture of the breakout board to RT board wire? IT could also be the rear time of flight causing the issue. The other possibility is the protection circuit tripped because the battery was low.

You can fix that by unplugging the battery - both the battery and balance line (yellow and white connectors on the battery) - and then plugging it back in and turning on the device with the charging cable plugged in.

  • I pulled the battery and followed that reset procedure
  • The eyes change
  • The chest color changes again
  • Still no movement of the wheels or head

@jody, sorry you are having so many issues! @areeya could you take Jody to slack to troubleshot?

@jody - I can see Areeya and Mike (operations) working on this issue - they’ve got motor controller and real-time boards in their hands and talking through what might be happening.

@tenwall Yes. it looks like we are replacing the motor controller. Thanks for the responses @Daria

@mysticmike @vlad and @slava

1 Like

But was it a fun 30 minutes, @jody? :wink:

Amazing 30 Minutes. I was just about to write my first little program. Can’t wait to get it going again.

2 Likes