Home Community Blog Buy Now
Blog

Misty Community Forum

Misty cant locate captured audio file

Trying to run the Conversation skill already created. I keep getting an error it cant find ‘capture_HeyMisty.wav’

Any ideas?

{data: “Misty is listening and will beep when she hears ‘Hey Misty’.”}
skillrunner.js:511 "‘Conversation’ Debug => " “2020-07-14T14:00:48.7528223Z”
skillrunner.js:518 Misty is listening and will beep when she hears ‘Hey Misty’.
skillrunner.js:511 “Calling command ‘Debug’” “2020-07-14T14:01:06.6482341Z”
skillrunner.js:518 {data: “Successfully captured speech to capture_HeyMisty.wav”}
skillrunner.js:511 "‘Conversation’ Debug => " “2020-07-14T14:01:06.6482341Z”
skillrunner.js:518 Successfully captured speech to capture_HeyMisty.wav
skillrunner.js:511 “Calling command ‘GetAudioFile’” “2020-07-14T14:01:06.6482341Z”
skillrunner.js:518 {fileName: “capture_HeyMisty.wav”, callback: “ProcessAudioFile”}
skillrunner.js:511 “Calling command ‘Debug’” “2020-07-14T14:01:06.7893563Z”
skillrunner.js:518 {data: “{“Status”:4,“ErrorMessage”:“Could not find the audio file ‘capture_HeyMisty.wav’.”}”}
skillrunner.js:511 "‘Conversation’ Debug => " “2020-07-14T14:01:06.7893563Z”
skillrunner.js:515 {Status: 4, ErrorMessage: “Could not find the audio file ‘capture_HeyMisty.wav’.”}
skillrunner.js:1149 Stopping Skill ‘Conversation’…

Tried this with the API Explorer and cannot load any files. Command Center can play them…

Hi @wlaubach6, This is indeed odd. I’m sorry you are running into this issue and thank you for trying out the conversation skill.

I just wanted to confirm. The API explorer can’t load any files at all? or just capture_HeyMisty.wav

Also, the command center does indeed find and play capture_HeyMisty.wav?

Hi, The api explorer cannot play any files. Same Error cannot find file.

Command center can find capture_HeyMisty.wav and play it. If you need any more info let me know.

Wes

Not sure what happened,but it magically started to work today

Now today, same error…can anyone help?

Hi @wlaubach64,
Is this the concierge skill ?
Could you share a link to the repo you are following instructions from…

Hi,

I am using the Conversation skill located on github. I have been trying to track why this is happening. I have narrowed it down to sometimes if i restart misty it does not work. Same code, no changes.

If it does not work, i reboot misty until it starts to work. The code is exactly what the converstion skill on github. Not sure why it is happenning, but seems to be located in startup code of misty.

No other skills are running when i get the error. i have not tried the concierge skill.

Thank you for your help.

Wes

Thanks for the info @wlaubach64 … That helps…

I was able to recreate the same issue on a non-latest-release build… but on the latest release build, that is
Robot Version: 1.17.3.10530
Sensory Services Version: 1.17.3
I do not see this error show up…

Could you share the Robot Version# and Sensory Service Version#…
You could find it in the Command Center’s System Update area in the top of the page…

Hi,

Here is the info.

  1. {androidHardwareId: “a54a0d8f2e586105”, androidOSVersion: “OpenQ820_O_v4.1-OPM1.171019.026-scripts1.0.1-patch1.0.5”, batteryLevel: {…}, currentNetworkId: 0, currentPreSharedKey: “”, …}

  2. androidHardwareId: “a54a0d8f2e586105”

  3. androidOSVersion: “OpenQ820_O_v4.1-OPM1.171019.026-scripts1.0.1-patch1.0.5”

  4. batteryLevel: {chargePercent: 1, created: “2020-07-24T14:18:48.818356Z”, current: 0.179, healthPercent: 0.99, isCharging: true, …}

  5. currentNetworkId: 0

  6. currentPreSharedKey: “”

  7. currentProfileName:

  8. hardwareInfo: {rtcBoard: {…}, mcBoard: {…}}

  9. ipAddress: “192.168.1.122”

  10. macAddress: “00:d0:ca:00:5c:26”

  11. networkConnectivity: “InternetAccess”

  12. outputCapabilities: {halt: “y8arjY”, resetImu: “a8RSHl”, messageStream: “DypFfI”, actuator_HeadPitch: “Awb61F”, locomotion: “VyExVx”, …}

  13. robotId: “00A0C6AB9030-00800F117000~a54a0d8f2e586105~294941-540160565~1835038-540488760~2506”

  14. robotVersion: “1.17.3.10530”

  15. sensorCapabilities: {/Sensors/Microphone: “mic”, /Sensors/StringSensor: “string”, bump_FrontRight: “bfr”, toF_DownBackRight: “tofdrr”, /Sensors/CapTouch: “cap”, …}

  16. sensoryServiceAppVersion: “1.17.3”

  17. serialNumber: “20194803958”

  18. sku: “060-000001”

  19. structureCoreDeviceInfo: {structureCoreDriverVersion: “0.9.7”, structureCoreFirmwareVersion: “0.9.7”, structureCoreSerialNumber: “2506”}

  20. windowsOSVersion: “10.0.17763.253”

  21. proto: Object

Thanks for your help.

Interesting… One more piece of info from you could help with the debug.

Is it constantly not working across robot reboots ? Or do you see this error pop up at a random reboot cycle?

And I am sure you would have already tried this… If not, Try a Targeted Update on Sensory Service from the command centre. Then reboot the robot once and run the skill… Still see the error in this case?

Hi,

I just updated the sensory service, so far so good. I rebooted a few times since and no problems.

I will update, if i get the problem again.

Thank you for your help

Wes

1 Like

Hi Sridhar,

I am also facing the same issue, I have done the targeted update on Sensory Service, rebooted the skills, but the issue is still there. Below is the error message and the robot version. Can you please check and update

image

image