Robot Not a Dev? Buy Now
Not a Dev?

Misty Community Forum

Misty Beta Trouble shooting

Perhaps a separate area for Documentation. I am fine with writing in
a formatted version or use a template and make it more ‘professional’ looking.
But here is a quick outline.

Trouble shooting guide at least on the web, so far what I collected:
 Misty:
   1. Screen/face originally did not come on:
        - Check the ribbon cable in the head
   2. Head down and not moving.
        https://community.mistyrobotics.com/t/dead-neck-servo/528
        - Check the battery is connected/installed (and power if battery is not charged :) )
        - Check to see no 'loose wires' disconnected 
          (If you find a issue it normally helps to take a picture when you upload and ask).
        - We have seen issues with needing to poweroff and unplug battery then power on.   More information on the link above.
   3. Wheel/track motors not moving.
       a. Is the battery plugged in and charged (with or without the plugin).
       b. If it also has a sad face/moan see #4 (check for versions.xml)
             ssh defaultaccount@<ip-addr> 
             .. no password ..
             cd Documents
             rename versions.xml backup-versions.xml
       c. If it was working and drove and stopped:
          Either:
            * Put it up with the box between the wheels and let it sit for 5-10 minutes.
            * Power it off, unplug for at least 10 seconds and power the main switch and the u820 carrier board back on.
       NOTES:
          - when I originally received he Misty I had not plugged in the battery and plugged in the power the
            lights went on and no motors (power off, unplug the power, plugin the battery, re-plugin the power), 
            and on power on motors started (head raised up) and wheels worked.
          - After driving 8 feet, drive motors stopped working.  After sitting 1-2 hours they worked fine again
          - While on the desktop on the box. Motors suddenly stopped, head dropped. Lights/face were still on.
   4. Has a 'sad' face and moans
       - To prevent the update process from running and if your 820 is not booted up in time it will fail on that step and play the sad sound you can delete the versions.xml file from the documents directory
   5. WiFi not connecting
        Linux/Mac: (just send 1 ping request)
            ping -c 1 <IP address>
        Windows:
            ping <name> /4
         * We would at times have to wait or just reboot
           sometimes only http://<IP Addr>:8080 works
           but API interfaces do not. So Windows reboot
           or sometimes waiting a hour resolves.

 CompanionApp:
   1. Complains it failed to connect WiFi
       * I believe this complains if you already have a connection
         (I need to confirm if it is even if you are changing to a new WiFi)
       * Double check the DeviceInfo (and/or reconnect to bluetooth)
         If the IP address is listed is listed with the IP address
   2. Could not connect or see Device Info or drive
       * Reconnect Bluetooth
   3. Could not drive the motors
       * Ensure you are connected via bluetooth
       * Misty is on, battery connected and charged or battery + plugged in and on
         both the back of the Misty power switch and the u820 carrier board (a quick green blink).
       * Misty with the face/eyes
      If there is still a issue:
       * Power off Misty and power up again

      Problem: Misty boots and the api commands work but none of the motor commands do. (stanton) 
         https://community.mistyrobotics.com/t/motors-not-working/497
         Troubleshooting: Updating Misty, Hard Resetting, Checking for command errors… Check the hardware inside!
         Solution: Make sure the motor controller board is set all the way, it had unset during shipping
                   but was hard to tell. need to remove the panel on the right side (when staring Misty
                   in the face). Once I pushed it in, the commands worked and another red light appeared
                   on that board. I thought it was a short in a cable but not so.
1 Like

These are terrific, @markwdalton! Thank you!