Robot Not a Dev? Pre-order Now
Not a Dev?

Left wheels don't work at all


#1

I’ve been able to connect to my Misty and send it commands with the sample index.html in the API Client! Yay!

Unfortunately any commands that involve the left wheels don’t work. It made some weird noises earlier when I tried to run the left wheels, and now it makes no noises when trying to run the left wheels, and just does nothing. I’m guessing this is a hardware issue, or perhaps wire connections loose or something. If you have any ideas of things I could look at or try, let me know. I can also bring him in for surgery next week if you guys want to take a look.


#2

Cameron: can you check to see whether the track is squarely on the left wheels? Of the robot was placed on carpet and tried to turn; the track can easily come off and it won’t move. I suspect that is NOT the case given how you described the situation (usually the motor will make some sound). Also possible the motor burned out (although shouldn’t have). One other item I could imagine is battery - so you could try working with the power cable plugged in so we know it has all the electrical juice it requires… let us know…


#3

thanks for the suggestions, @tenwall . I have only tried to run Misty on hardwood floor, and sitting perched on his box on my desk. The very first time on the hardwood floor he only did right turns. That’s when I noticed the rubber track was not square on the wheels. I adjusted it back on, but the left wheels still didn’t move the next time I tried.

I just now plugged Misty in to power and tried the left wheels again. It makes a slight high-pitched noise now, but the wheels still don’t move. Here is a video of what happens and the noise:


#4

Definitely doesn’t sound good. It could well be failed motor / HW… I’ll see if I can get Steven on line (firmware guy who has spent a lot of time with the motors.)


#5

Cameron, lets see if we can figure this out. Unfortunately I think my ears are too old to hear the sound that the robot is making while trying to turn the left wheel. It sounds like silence to me. However lets try a couple things that will help us narrow the problem down. Would you mind doing a couple things for me?

  1. Power down the robot and try to manually turn the left track. It should not spin too freely, but it should spin with a small amount of effort. You can spin the right track to see about what it should feel like.
    1a. If it feels locked, like something is jamming the system, verify the tracks and wheels are aligned and nothing is blocking them. If everything looks good, probably the motor is bad and will need replaced. We can do that in just a few minutes at Misty.
    1b. If it spins very easily. Look under the robot, and you’ll see the motor and a black disk on the end of the motor shaft, near the center of the robot. When you spin the track, touch it with your finger to feel whether the disk is rotating as well. If the disk is not rotating, then the set screw that holds the wheel to the motor shaft has likely backed out. If that is the case I can provide you with instructions for resetting it.
    1c. If it spins but takes a small-moderate amount of effort, similar to the right track, make sure you’ve got the robot powered with the power supply and give it the command to turn at full speed. If it isn’t told to turn at full speed it could whine and not turn. We can try removing the track and giving it a command to move as well, which will help us indicate whether the motor is bad or if the track is too tight. I can provide instructions for that as well.

Let me know what you observe in these things. If you would rather walk through it with us I’m happy to go through it with you this week at Misty.


#6

Thanks for the troubleshooting steps, Steven.

I tried manually turning the left track but could not get it to move. However, I also tried manually turning the right track (which functions properly) and could not get that one to move either. Perhaps I’m not applying enough force, but I am a little leery of breaking something.

I turned the robot over and felt the motor’s black disk move on the right track, but nothing on the left track.

I removed the track from the left wheels and tried everything again, but still nothing.

Can I bring it in for a little TLC? Does tomorrow (Weds) a little before noon work? Or otherwise please suggest a good time.

Thanks!


#7

Hey Cameron.

Yes tomorrow before noon will work if its convenient for you. Lets get this sucker up and running for you!


#8

Great, I’ll stop by then. Thanks!