Robot Not a Dev? Buy Now
Not a Dev?

Misty Community Forum

Latest update not detected by Misty

I noticed there is a new update for the MistyI with CAN bus, when I check for an update using the app or using the Misty API via the web, it says there are no new updates yet checking the version numbers clearly indicates otherwise.
Here is what my versions are via the app.

This did just go out today. Here are the release notes:

https://community.mistyrobotics.com/t/8-2-18-release-notes/773/3

I’ll check in with the team to see what is going on in your app.

@kyle Can you perhaps speak to this? Thanks in advance for helping us sort this out or adding in additional folks, if needed. There are two things going on here:

  1. The version numbers that Matt sees on his Companion App for Home Robot app and Sensory Services app are not current (compare his versions above from those in yesterday’s release note copied below), however the Windows IoT Core version is current.

Windows IoT Core OS: 10.0.17134
HomeRobot app: version 1.1.7.0
Sensory service app: version 1.1.283

  1. Neither the Companion App nor the API are saying there are new updates for him. Could this be because his version of Windows IoT Core is current?

At what time was this reported? The update went live yesterday afternoon ~2pm mountain time.

This would have been after I made the release note pubic.

@station - Note that I’ve now been told that Windows IoT Core was not updated with this release. Certainly, the HomeRobot app and Sensors Service app were, so we’ll have to figure out what’s going on. Let us know if you’ve tried again this morning and how it goes.

Hey @station, this shouldn’t make a difference, but could you try triggering the update via the API Explorer?

@Chris Indeed Sir, I tried both through the API Explorer linked, and the app last night both saying there was not an update available. I can try again tonight, am not near Misty atm.

@station Worth a shot, in that case I’ve got one other thing for you to try. Expect to see an email with instructions from @kyle soon!

1 Like

Update:
got home and turned on Misty around 8:30pm, turned on app to connect and Misty when straight into updating before I connected.
Misty rebooted, then updated again - then Happy Misty sounds.
Had to reboot my phone to connect via the app at that point, but was then able to check the version and it is in line with the latest release now.
I ran the “mapping” to make sure the firmware got picked up for the structure sensor and it seems to be in order, so no other errors so far.
checking for updates says none available as expected.

2 Likes