Robot Not a Dev? Pre-order Now
Not a Dev?

Misty Community Forum

Inconsistent behavior in arm movement commands

Arm movement commands behave inconsistently when you pass in a position value instead of degrees. Specifically, when you pass in a value of 1-10 and specify a Unit type of position, arm movement is as follows:

  • 1, 8, 9, and 10 point the arms as high as they are allowed to go
  • 2 points the arms down
  • 3 brings the arms up a little, 4 a little more
  • 5 points the arms straight in front of robot
  • 6 and 7 point the arms incrementally upward from straight ahead

While a fix is in development to adjust the behavior of these commands when using position values, most commands in Misty’s API use degrees as the default unit of measurement, and we recommend using degrees wherever possible across all head, arm, and locomotion commands.

We’re experiencing issues when giving the arms a degree value. If you run the same bit of code repeatedly Misty behaves differently each time. Sometimes one arm will move and other times not. I’ve tried rewriting the code several different ways and am getting the same result each time.

Thanks for posting this here :slight_smile:

Could you post the code you’re running that’s giving you this result?

@rwines Out of curiosity, are you running multiple arm movement commands in your code? EG are there multiple places where arm movements might be called?

We are running multiple arm movement commands. We were attempting to get a excited effect —like waving arms up and down.

But only one arm moves consistently—and it switches back and forth between which arm is moving.

Just to double check, did any of your attempts involve the misty.MoveArms() method? This command should let you move both arms to new, different positions simultaneously.