Robot Engage Blog Buy Now

Misty Community Forum

I put in a wrong Wi-Fi name installed

Out of the box I put in the wrong Wi-Fi name.Not surprising I cant connect the command center. How do I fix this? When I reuse the App via Bluetooth it find and connects but the the add closes, with out asking for Wi-Fi information. Is there a way of resetting or clearing a wrong Wi-Fi settings? Sorry if this is covered already.

Hi Steven,

Are you able to connect your phone to the same WiFi network that you connected Misty to? If you have the app and the robot on the same network, you should be able to follow these steps to change Misty’s WiFi network in the app.

If that doesn’t work, or if you’re having other issues with the app, let us know.

Thank you, Johnathan for your reply. I may not have made myself clear as to my problem. The Bluetooth app is on my wife’s IPad. Misty is? on a network that does not have the full name as my home WiFi network. DEA2C-5 not vodafoneDEA2C-5. So no they are not on the same network because Misty is not on a network. I am assuming that Misty has the upper band WiFi capability. I am looking into the potability of connecting Misty direct to my home network with a Ethernet to USB adapter, as I saw somewhere in the notes. I have been told that I need to know what “chip set type Misty has” that the adapter needs to suite. is this information in the documents?

@steven.graham in the Misty2 companion app, once you’ve selected the robot and it connects you can go to settings and press the WiFi button and reselect the correct network. The robot should play a sound when it connects successfully

Thanks Vlad, When I start the “app” on the IPad it shows Misty’s Bluetooth name “MISTY_#####”. when I select it the app closes. The first time I used it, it asked for my WiFi name and pass word. That is when I put in the incomplete name. Are you referring to this as the “Misty2 companion app”? Because the WiFi is not connecting the page on the site page for re selecting the correct network is not working. It does nothing. Is there a reset button or pin I could pull up or down on one of the boards that would put it back to its start configuration? Could the app be faulty?

The app shouldn’t be closing. Try it on a different phone/device or try re-installing the app.

Alternatively, if you cannot get the app to work for whatever reason here is a way to onboard the robot to a WiFi network using a USB drive.

  1. You need a USB drive formatted to FAT16, FAT32, or exFAT
  2. Create a new directory called misty on the root of the drive.
  3. In the misty directory, create a new text file named wifi.txt . The contents of this file will be used to onboard the robot to a specific Wi-Fi network.
  4. Edit the contents of wifi.txt to include the following two lines:
    • Line 1: <SSID>
    • Line 2: <password>

Example wifi.txt:

  1. Save your changes and eject drive from your computer
  2. Boot up Misty. Wait for her eyes to appear fully open.
  3. When the robot is fully booted, connect the USB drive (with your wifi.txt file in the misty directory) to the USB port on Misty’s back.
  4. When you insert the drive, Misty checks its contents for the misty directory. When she finds it, two things can happen:
    1. First, Misty looks for the wifi.txt file. If she finds it, she uses the credentials you saved there and attempts to connect to this network. Additionally, she creates a new file called onboard.txt in the misty directory. This file contains Misty’s IP address, which you can use to connect to her web-based tools and send her commands. (This is the same IP address that should typically be returned in the Misty App.)
    2. Second, Misty creates a logs directory within the misty directory, and dumps all of her log files into this directory.

Misty should play a sound when she has successfully connected to the network, but if she doesn’t, that doesn’t necessarily mean she hasn’t connected. (If you don’t hear the sound, try leaving the drive connected for one or two minutes, then remove it and connect it to your computer to see if the connection was successful and onboarding.txt is created.)

Hi Vlad, thank you for these suggestions, I will try the USB drive tonight.
Last night I tried creating a replica cell phone on my Windows 10 laptop. I used a program called BlueStack, which (I am told) act like an android cellphone. I installed it and downloaded the Misty App in it’s environment. When I ran it, There was no indication that the Misty was found.
When I use the Windows settings and looked for Bluetooth devices the 5 digits of the Misty serial number would turn up, and when I command a connect, Misty would respond with a Chime sound. I conclude that the BlueStack could not find the Bluetooth capability on the laptop.
Later in the evening I received an email that a Samsung cellphone had joined my network. This had me confused as I do not have a cellphone of that brand. Later still I was working through the BlueStack settings (looking for Bluetooth settings) when I found that BlueStack was emulating a Samsung phone.
I take it that looking at the USB is part of the boot up sequence. I have one other question. We have two bands on our WiFi which are named"DEA2C0 and DEA2C-5". I will initial assume that as Misty is a very new device it will be using the Hi band (DEA2C-5). Thanks again for your help.

A big thank you to Vlad. My Misty2 is now doing things under my command.It all worked as per the instructions Vlad gave. The one thing that may be a slight problem is, if you are not familiar with creating “TXT”. Under Windows start Word, create a new file. It does not matter what font and size. Inter the two lines, (you network name, in full) line two (network password) these can be found on your modem.
Use “Save as” and save this file to your USB thumb drive. Note you will see a drop down menu called “Save as type:” with a list of file formats. Select “Plain Text” then press save. This is how you get this information to your Misty2 via the USB socket. I have no idea of now to do it on other than a windows system.
Again Thanks Vlad.