Robot Engage Blog Buy Now
Blog

Misty Community Forum

Heartbeat failure and charging issues

Hello everyone!
I am having issues with misty 2. It is keep displaying error message on screen heartbeat failure. Please reboot the robot and if issue continues contact support. I tried to reboot it multiple times and it is doing the same thing. Also I tried to charge it using wireless it is making some noise even if the robo is off and not displaying any orange or yellow light notifying it’s charging. It is keep showing the purple light.
Does any one know what’s wrong with it and how to fix it?

Hi @sp22, welcome to the community!

The heartbeat failure message indicates a communication issue with the robot’s firmware. It’s possible your robot installed the latest software, but certain firmware components failed to upgrade with the rest of the system. Here’s how we can check if that’s the case:

  1. Boot up your robot. Make sure she’s connected to the same local Wi-Fi network as your computer.
  2. Open your web browser. Go to the URL <robot-ip-address>/api/device, where <robot-ip-address> is your own Misty’s IP (i.e. 192.168.7.33/api/device)
  3. Paste the results in a reply to this thread.

What we’re checking here is the firmware values for your robot’s mcboard and rtcboard. They should be 1.7.4.2. If that’s not the case, we can walk you through the steps to perform a targeted system update :slight_smile:

Will try that and will post the results here.

1 Like

Yes it shows 1.7.4.2 as firmware version. Don’t know whats going wrong? No skills are uploaded. Is there any way I can reset misty?

Thank you for checking those numbers. Your firmware is up-to-date.

I’ve been chatting with our team about the issue with your robot, and we have a group that’s actively investigating the root cause. One thing that could help us would be to get a diagnostic report from your robot with logs from the past few days. When you have a few moments, could you follow these instructions to download a diagnostic .zip file from your robot using the Command Center? You can attach this file to an email to support@mistyrobotics.com. Our team will dig into the logs as soon as we receive them.

Currently, Misty can’t be reset to her factory settings, and her software can’t be rolled back to a previous release. I understand your Misty II can’t be used in its current state, and I’m very sorry for any difficulties and frustration this has caused. Know that we’re focused on the issue and are working to find a resolution as quickly as we can.

I will keep you updated in this thread or via email with any progress; please reach out here if there is any trouble in getting a diagnostic report.

I already sent out the log files earlier to Allision. will send it again today once I go home.

1 Like

Thanks @sp22 – we can use the logs you’ve already shared. I’d not realized those were associated with your robot. No need to re-send :slight_smile:

If you want I can provide the ticket number.

I discovered I had a similar issue with having an earlier firmware release. I used the SDK Command Center to do a targeted update for all 3 options.
I checked my Misty’s values using Get Device Information in the SDK API Explorer. The values are now correct.

I already tried that twice but it is not helping me at all in my case. I did not turn my misty for a day and it seems like battery is charging now, it still shows 0% on command center and its not displaying any LED light.

Hi @sp22,

I just wanted to check in with an update. This morning our team is investigating a robot in our office that is presenting this same issue – firmware is up-to-date, but robot exhibits a hardware heartbeat failure. We don’t have a resolution yet, but we will keep you informed of our findings. I’m optimistic that we’ll have an update before the end of today. Again, I’m very sorry for the inconvenience and frustration you must be experiencing. Thanks for your patience as we work to get your robot back on track.

1 Like

While I am waiting for an update, Can I still use my Robot? I mean can I still try try to load the skills into it or I need to wait until its been fixed?

Hi @sp22,

I believe that @woo reached out to you via email, but in case you check the forums first:

Please do upload skills and connect Misty to the Command Center to try out capabilities. Some of the capabilities in the Command Center may work despite the robot’s hardware heartbeat failures, and using them shouldn’t harm the robot in its current state. If you do, please let us know when you run into unexpected behavior, as this may help us better diagnose the issue.

Our team is still investigating with the robot we have in-house that’s exhibiting the same issues, and we will report back as soon as we have more informaiton.

Hello Johnathan!
I just saw that misty has new update released yesterday, should I try to upgrade it to the latest version?
Do you think, it will help to solve the issue I am having with misty.?

Hi @sp22,

I do think you should attempt an upgrade. The update includes changes to Misty’s firmware that should improve the performance fo Misty’s time-of-flight sensors and hazard system, which could be related to the issues you’ve seen with your Misty II.

That said, upgrading isn’t a certain fix. Given what we’ve learned from the log files you shared and our own analysis of the robots we have in the office, we’d like to suggest disassembling your robot’s base to check the time-of-flight sensor connections. You can do so by following the directions under Part 3 of this post.

The log files you shared point to an issue with the front left edge sensor, so we’ll want to pay careful attention to that connection. If anything looks broken, dirty, or unusual, please take a picture of what you see and send it to us (either here in the forums or to our support@mistyrobotics.com email address.) Then try disconnecting the sensor, inspect the interior of both connectors for anything odd – especially bent pins – and reconnect the sensor.

You only need a phillips head screwdriver to disassemble Misty’s base, but if you’re not comfortable taking Misty apart without guidance, let us know. I’d be glad to set up a time to walk you through the steps linked above over a video chat.

It shouldn’t make a difference whether you attempt an update or check the connections first. Thanks for all your patience as we work through this process. This is pretty unusual behavior for Misty, and so we’ve been a bit stumped, but I think we have a path forward. If your robot does install an update, and checking the connections doesn’t resolve your issue, then we’ll likely want to look into replacing your Misty (at no cost to you).

3 Likes