Robot Not a Dev? Pre-order Now
Not a Dev?

Misty Community Forum

Erratic ToF sensors

I received my Misty II today, I followed the instructions in the included booklet which said that the battery should be charged and to download the app. Downloading the app and connecting to Misty wasn’t a problem. The battery level indicator read - -%. I tried several times to move misty with the joy stick. Occasionally it would go in reverse. Sometimes it sounded like it tried to turn, it never went forward. I even increased the drive speed all the way to fast and held the same command on the joystick for up to 30 seconds. I figured the battery was low and plugged it into the accessory wall pack, figuring that would be quicker than the charging base.

After over 3 hours of charging I tried using the SDK program. Misty connected immediately using the IP address and went through a series of updates and restarted. The battery percentage in SDK read 88%. I tried to center the head. It took some commands and ignored others. I tried to drive it and it wouldn’t drive at all in any direction using either the arrows or the time of flight command. I was able to change the eye expression to love but it wouldn’t go back to admiration, the eyes seemed to freeze in between two expressions. Occasionally it would play sounds. I powered it off and restarted it switching back to the app with no changes in being able to drive it.

Quick update. It’s still charging, up to 92% now! I started it back up and checked the front sensors. It seems they are grossly off which may be causing some of the driving operations. Misty is on my desk, the nearest wall is about 3.5 meters away. Both of these pictures were taken with nothing in front of her about 30 seconds apart.

Another picture with all the sensors checked. The rear sensor stays steady. The front sensors are all over the place. And a picture (the best I could do) to show how far away objects are away from the rear and the front. Thank you for any help.

One last update and I’m shutting down for the night. When I press the bump sensors while monitoring them in the SDK, it takes about 37 seconds before they light up. That seems like an awfully long lag time after a button press before the SDK registers it.

@ScottC - thanks for sharing all of this tonight. Our team will dig in on this in the morning. I’ve also moved this post into the Developer Support category which notifies people to jump in and help out.

I am starting here since we already spoke about the charging issues over chat. Are these all commands you are sending via the Command Center (I am pretty sure that is what you mean by SDK program)? If so, when you experience failures—where Misty doesn’t complete the task are you seeing error messages pop up from the bottom of the screen? Can you download the lo files next time you experience some issues and share them with us? Let’s start here. I’ll look at some of your other messages here too.

1 Like

It is possible (but unlikely) that these sensors are dirty—even from the factory. We know that smudges or dirt in front of the ToF sensors can cause readings to be off. There is also a possibility that they want need to be re-calibrated. We can work with you to figure this out.

1 Like
  1. The phone app continued to show --% battery, but the web app did get the readings.
  2. I also noticed delays in response to no response on moving at times. But overall it worked for me to move misty II.
    • I also noticed issues with ‘ping’ times to the device 10-20x slower than other devices.
      (I am just curious if you are seeing a similar issue)
  3. Head movement, sounds and expressions seemed to work perfectly for me and my kids really enjoyed those features.
  4. I still have charging issues on the wireless base.

Also at first I could not get the logs, but now I can. From the Web command-center, you can download and look at the logs, which may give a hint.

Mark

2 Likes

Hi @ScottC! Thanks for all this info, I’m curious what device are you using with the Companion App? Is there any chance you might be able to snag a short video of what you’re seeing with the driving via the app? Not driving and occasionally reversing is a new one for us.

Also, when you connect to your robot via the Command Center is there any indication that there is an available update?

Lastly, would you be able to able to send us a diagnostic report? You can do so by scrolling to the bottom of the Command Center, in the ‘Advanced’ section and clicking ‘Run and Download’

image

I’m sure we’ll be able to get the issues resolved :slight_smile:

1 Like

Thank you for everyone’s help and replies. I’ll try and address these the best I can. I went to advanced, run and download diagnostic report and a yellow box said “unable to get report”. The plus side is I was able to move the head and it only missed 1 or 2 commands. I also tried “download log file” option near the top of the command center, but nothing seems to happen. The command center says there are no updates. It did update yesterday when I first connected it to the command center. I have a video of me trying to use the app on an iPhone, the forum won’t let me post a video. If you want I can send it to the support email.
Thank you again. Scott

Thanks for continuing to troubleshoot here, Scott. Please do send the video to us at support@mistyrobotics.com - You are right that there may not be a direct upload option for videos. Need to post them somewhere and share.

I found this thread which seems to be very similar to at least one of the issues I experienced. How would I get an error report like this user did?

Hi @ScottC!

You can get view the full ToF event message (status values and all) by setting up your own generalized subscription to time-of-flight event messages. Here’s how to do that through the Command Center interface:

  • Connect your robot to the Command Center
  • Scroll down to the Sensor Data section
  • Click Advanced Options + (in the bottom left hand corner)
  • In the modal that opens, configure a new time-of-flight WebSocket connection. Try filling out the form to look like this:
  • Click Subscribe.

This should start Misty sending event messages that show all of the event properties from each ToF sensor every 500 ms. Those messages will appear in the JavaScript console in your web browser.

(For best performance, it’s a good practice to unsubscribe from an event type when you’re done using that data. To do this, open the Advanced Options modal back up, enter the name of the event (ToF in our case), and click Unsubscribe.)

Following the above steps will get you data from all of Misty’s ToF sensors, which can be kind of a drag to parse. If you just want to see the data from one sensor in particular, try applying “event conditions” to filter out messages unless the sensorId matches a specific value. For example, you’d do this to get message only from the front right time-of-flight (toffr):

You can find the sensorId for all of Misty’s time-of-flights in the developer docs :slight_smile:

Once again, last update for the day until I hear something back. After trying again, I was able to get a diagnostic report and emailed that it to help and support. In the mean time, probably 75% of the report is errors and a large portion of it is tof sensors switching between true and false even though the robot was stationary with nothing in front of it. Here’s some pictures of my brief scan through it.

Wanted to make sure you saw the reply just before this one. You must have both been drafting this at the same time.

Thank you, I was typing out a general reply when you sent this, I’ll try this now as well and report back.

Roger that. I’m taking a look at your log files now, and seeing lots of WrapTargetFail messages for your Misty’s front center ToF. That’s status code 207, so it may be interesting to check for that in your custom subscription.

You may have already tried this, but I’d be curious to see if you get different results when you set Misty on the floor with a box, block, or other object within a few feet of the ToF sensors. It might also be worth testing your ToF values with Misty in another room, with different ambient lighting. Typically the ToFs perform best in low lighting around darker colored objects that don’t give off a lot of glare. If the performance is the same regardless of object distance and ambient lighting, that could help us rule out environmental factors.

1 Like

Thank you Jonathan. I tried to get the sensor data 3 times both ways that you suggested, no values showed up on my computer. On the last try I noticed a brief message on Misty’s face that was in red letters saying something to the effect of a heartbeat error and to restart and contact customer support. :slightly_frowning_face:

Noted. That “Hardware Error” message typically means there’s an issue in communication between the main app that runs on Misty’s 410 processor and her realtime controller / motor controller firmware, which could explain why you weren’t getting values through your custom subscription. That message typically resolves itself, though in the (ideally) rare cases it doesn’t, Misty requires a reboot.

If you still have time for troubleshooting today, would you mind running another diagnostic report and sending it to our support email address? I’d like to capture anything in the logs that may have triggered your heartbeat message. Thanks for all your patience as we work through this.

No problem. Thank you for all your help. I will fire it back up and try to get a diagnostic report to send off. Then I’ll place it in a different room (lighting) to check sensor values there. Thank you again.

2 Likes