Robot Not a Dev? Buy Now
Not a Dev?

Misty Community Forum

Dead neck servo?

So another fun event, Misty was hangin’ out next to me and decided she was done looking up, the servo just kind of gave out and hasn’t come back even after a few power cycles…
The wheels work, so I don’t think it’s the motor controller this time. There is no hum or sound like the servo is getting power either.

1 Like

Hi Matt, that is a bit concerning. Was the robot charging at the time? And do you know the battery voltage?

It did indeed have the adapter plugged in. The current voltage is 12
18%20AM

If you remove the left wing and look near the boards there is a 3 pin cable coming from the servo (yellow, red, black). It should plug into a male connector whose wires run back to the large heat-shrunk module. Can you double check this connection is still attached and the wires are not damaged?

I apologize I don’t have a robot handy to snap a picture (I can do this in the morning).

And head is not back up after “off and on” procedure?

Any update on this? I had the same type of problem.
It was plugged in, powered on and suddenly the head went down.

  1. Power cycling, the head did not power up.
  2. What did work for me was:
    a. Power down
    b. Unplug the power
    c. Unplug the battery
    d. Wait 10 seconds, turn on the switch (to make sure it discharges)
    e. Turn off the switch
    f. Plugin the battery back in and the power and turn on.

Then the head was active again. (Now I did not try other combinations
so it may be just one of those steps). But in case it helps your situation.

Mark

1 Like

Hi Mark, thanks for the detailed description, super helpful!

When this happened to you, did other aspects of the robot function? You situation sounds like power may not have been reaching the servo until the battery PCM reset.

@station, I’m interested to hear what happens if you perform the steps Marks outlined.

The lights were still on, I did not test the wheel motors or other functions.
I was doing more work (job) and suddenly the head just went down. So I was
curious if the power cycle would work (as station found it did not for him and
it did not for me). If it happens again I will check the other functions.

I’ll give it a wiggle this evening, thanks.

OK, so I unplugged the battery and adapter for ~12 seconds and then plugged it back in and strangely when I flipped the switch back on… nothing. odd. so then I plugged the power adapter back in and the then flipped the switch on and the neck worked and it booted up fine. that had me wondering about the charging of the battery, so after about 5 mins I unplugged the power with the unit still on and shut off instantly.
The red lights are on when the adapter is plugged in and the switch is off, but I wonder if it isn’t charging? I don’t remember if I had it plugged in today or not but I know it was on and running for about 4 hours last night, I can’t imagine the battery was drained from it just being off and connect for one day.

@slava yes, before doing as @markwdalton suggested, the head was not active even after a few power cycles.

Thanks guys!
It is quite interesting development. I will talk with Steven and Miles tomorrow.

@slava, as a follow up, I was kind of able to recreate the issue. I left the Misty I Beta unplugged this morning, then when I fired it up tonight, just on the battery (no adapter plugged in) it started just fine. I power cycled it once after about 10 mins. then booted it up again this time with the power adapter plugged in, about 5 - 8 mins after the neck just dropped dead again… :man_shrugging: odd, but hopefully that helps.

Thank you, Matt!
I will try to recreate it tomorrow, so we can check circuits. We had an idea on what is happening with head, but couldn’t test or prove without robot w “broken” neck :slight_smile:
Thanks again!

1 Like

I head the ‘head drop’ again. And I did a little more trial-and-error debugging.

  • Head dropped again. (2018-05-12 20:45/8:45pm CT)
    • I could not connect with the CompanionApp
      (More specifically: Bluetooth Connected, No IP address seen, and no control, capabilities not listed)
    • I could not connect with teh Misty API Explorer
    • Looking at the :8080 - shows it is still there, IP address is up (obiviously since
      I am connecting through it).
      - No motor, eye or LED change response.
      - Web said it was changing LED, Changing Eyes.
      - But at times complained about the connection issues
      - I tried the Python API which has reliably worked and that just hangs and I can get
      additional debug from Python. (Basically it just fails to establish a new connection)
      1. Turned off for 1 minutes
        • Returned power on the back and on the side board.
        • Booted, head remained down, eyes showed up
        • Web to :8080 showed the IP adress/bluetooth up
        • CompanionApp could not find Misty (I could see Bluetooth and re-pair with bluetooth outside
          of the CompanionApp) but the CompanionApp would not find Misty (even though bluetooth pair outside worked)
      2. Rebooted Misty again (power cycled) and powered on the side board
        • Eyes came on (head still down)
        • Finally Companion App connected (I see Capabitilties, etc).
        • Drive motors work
        • Now api-explorer also works, eyes, LEDs, and manual drive
        • websocket works and battery at 12.158
        • Head still down
      3. Unplugged the small white connector from battery to board
        Waited 1 minute, plugged back in, no change.
      4. Unplugged the main power from battery, no changes
        • eye changes still work
          Waited 1 minute, plugged back in, plugged back in and rebooted eyes, default lights,
          head still down. Reconnected IP and confirmed up. Now eyes/LEDs do not change either.
      5. Turned off power and pulled only the main power (Battery plugged in)
        • Tried to power on without power, and no power/LEDS/boot.
        • Waited 30 seconds
        • Plugged in, powered on, LEDs on, booting, head came up.
        • eyes on for about 30-45 seconds before Windows up/responsive from the :8080 web interface.
        • Not connecting via api-explorer
      6. Powered down Misty, wait 30 seconds and power up (and head went up also).
        • api-explorer now connects and works to change eyes, LED, motors work
2 Likes

I feel like I have seen this with network connectivity loss but I am not the best to help yet. I’ll do more here at home to see if I can get mine to exhibit this behavior.

It is no problem it is all working again. But I want to let you know/be aware of what happens so you can debug it now versus after release. :smile: And what I did to work around it. If you ever want other information captured, just write up what you want done and I will grab that information. (I wanted to find my laser thermometer but I hid it from my son too well he was using it as a cat toy). :slight_smile:

Thank you, Mark!

This is quite detailed and helpful info. It also confirms our suspicions about the reason for Misty dropping head.

Thanks again!

My neck still won’t come back now no matter what combo of things. The connectivity issues have started now after this latest windows update it seems, can’t connect via wifi now.

Hi Matt,
Are you trying to connect to WiFi by robot’s name or IP address?