Community Blog Buy Now
Blog

Misty Community Forum

Can't Seem to Update Misty II

I haven’t had a chance to power up my new Misty II since delivery, but decided to try it today. I can’t seem to get her to update OTA. The versions for my robot are:

Robot Version: 1.0.3.0
Sensory Services Version: 1.0.3
Windows OS Version: 10.0.17763.253

I’ve tried rebooting, changing to a different network, and even tried the targeted update - nothing. When I try [Robot IP]:8080, the standard username/password don’t seem to work either. I know I am a few updates behind, but is there any way to push an update so that I can get current?

Hi @timmydietz,

Glad you’re getting a chance to try out your production robot!

1.0.3.0 is the build that Misty left the factory with. If this is the first day you’ve booted up your robot, it might take up to 24 hours for Misty to recognize that there is an update available. We typically suggest leaving Misty turned on and connected to the wired AC power cable (perhaps overnight, though in my experience it usually doesn’t take that long) and then checking again to see if the update has installed.

If you still haven’t received a software update after 24 hours, then there may be another issue going on, in which case it will be helpful to have you download your robot’s log files and attach them in an email to support@mistyrobotics.com.

Thanks Johnathan…much appreciated. I’ll leave it on overnight tonight - will let you know if I continue to have any issues.

1 Like

Just to confirm, the robot is on a network that has access to the outside world?

The username and password for the robot are on a sticker on the bottom of the robot.

Hi Vlad, yes it is on a network with outside access. I can see the password on the bottom and will try again once robot updates.

@timmydietz did it update?

Unfortunately, no. I left it on all day and overnight one night, with other extended times on, all while plugged into AC.

Any suggestions? I have the instructions for updating manually using the :8080 interface if you know where the files can be sourced.

I don’t like to leave it plugged in for too long when unattended but if that’s what it takes, I can leave it longer…but anything to speed up the process would be great. Really looking forward to trying some of the new features.

Two things to do/try:

  • Go to Command Center and please see what System Update area says. Click on Get All Device Info and post the response from the web browser console here.
  • Pull the logs and send them to use. Command Cennter offers a quick way to grab the most recent set of logs from your robot in a .zip package. You can follow these steps to get the .zip, and then send it to us in an email at support@mistyrobotics.com

Command centre is greyed out, with no updates available, and still shows the factory versions of all software.

I’ll see what I can do about sending you those logs…will just need to find some time to get them. Hoping I will have time later tonight / tomorrow.

Ok let me know when you send the logs.

Hi Vlad…sent what I could get. When I tried the diagnostic report, it failed. I tried twice. I was able to login with the :8080 link and tried a Windows Update to make sure there was connectivity - it seems to be fine. I ran a ping by adding the “run command” option. I included results in the attachments I am sending you. Hopefully it will give you the information you need.

If you have any other way of getting the diagnostic report, please let me know and I will try.

Do you have a USB to Ethernet dongle? Something like this: https://www.amazon.com/AmazonBasics-1000-Gigabit-Ethernet-Adapter/dp/B00M77HMU0

Yes, I do, and have used it with Misty. What do you want me to try?

Most likely we’ll send you a new App binary to install and you need the adapter for that. But we’re also going to send you some instructions to get some more logs so we can figure out why this is happening.

Fundamentally, this seems like an issue with the Windows Update Store not updating its cache locally properly. We’ve only ever seen one other time this has happened and we’d like to see if we can find the cause.

One thing, if you can go to Windows Device Portal (Robot_IP_Over_Adapter:8080) and then click on Apps->App manager and send a screenshot of the apps running.

There you go - much better.

It’s been over 15 minutes since I did the steps you outlined, but I haven’t heard the sound or seen anything on Misty’s face to indicate the software is updated. How long does it take to complete? Should I reboot or any other steps?

Hi Vlad - UPDATE:

  1. Installation seemed to stall. Rebooted Misty using the IoT interface.
  2. When I connected to Misty, the app and Win OS were updated, but the sensory services had no value.
  3. Did a targeted update. First time stalled.
  4. Rebooted Misty (hard reset) - automatically updated the targeted update.

I now show these values:

image

Hopefully that is now up to date - please let me know if not. Thanks!

If you do Get Device Info and look in the web console what are the versions for firmware in the following block:

"hardwareInfo": {
    "rtcBoard": {
      "boardId": "655361-540160565",
      "firmware": "X.X.X.X",
      "hardware": "75.0"
    },
    "mcBoard": {
      "boardId": "3080214-540488760",
      "firmware": "X.X.X.X",
      "hardware": "74.0"
    }
  }

They all match the 2020.02.20 update release log values - I’ll assume that means we are good to go? Are we due for another release soon? I can check to make sure Misty is updating by herself.

1 Like

:+1:
Yes there will be another release this week. Keep an eye out if it auto-updates or not.