Robot Not a Dev? Buy Now
Not a Dev?

Misty Community Forum

Can't get my robot on Wifi

I powered up my robot, got it connected to Bluetooth and was able to drive it. Then, went to follow instructions for Blockly. Got an IP address, but Blockly never connected. (Tried Javascript API too - but was never able to get it connected to the robot). I’m using WiFI network “Misty-Guest”. Any suggestions? I’m going to reboot the robot and try all over again. (Also - I’ll be away from my desk much of the day…)

Hi Tim, thanks for the note. Sorry you are having troubles. Ciukd you please check that your robot and mobile device (and computer) are all on the Misty Guest network.

Thanks Ben. They are, indeed, on the same WiFi network (double-checked and triple checked that as the first thing). I saw the note in the Getting Started guide which was a helpful reminder.

1 Like

Also… I just tried again. Rebooted the robot. Reconnected to BT. Re-sent WiFi credentials (Success reported). Got IP address again – 10.0.100.218. Tried to ping that IP address from Terminal – no response to the ping. Confirmed, again, that mobile phone is on Misty-Guest and Computer is on Misty-Guest. Also… I’m not able to drive Misty I any more either – at first I was able to drive it, but just before reboot and now, I can no longer even activate the driving. Lastly… I’ve confirmed that the 820 is powered on (blue LED on SLAM sensor is glowing).

Just for grins… I switched my computer to the Misty-Staff network and tried to ping 10.0.100.218 (the IP address the robot is giving me via the mobile app). THAT WORKED. Which means, somewhere/somehow, we’re not fully wiping/erasing WiFi credentials. I’ll continue my work on onboarding. Either we’ve got to figure out how to completely wipe credentials OR we have to make sure that any robot that goes outside the office is a brand-new robot without wifi credentials.

Even though I can ping the robot, I can get neither blockly or javascript api to connect. When I look at the console for the javascript API all I ever get is timeout errors when it’s trying to post the commands.

Sorry you’re running into this, Tim! This was definitely the most problematic part of the process for Daria and I on Friday. It was never clear what made everything work in the end, but our process included iterations of all the following:

  • repeatedly checking phone/laptop/Misty were on same wi-fi with Bluetooth on/connected
  • rebooting Misty
  • reloading web pages

Hey Tim,

Just a minor note: I noticed you had success when you connected to a non-guest network. In my experience, most guest networks are not configured to allow connecting to other devices on that network.

Also, as donna mentioned reloading web pages, could you try running the API client in an incognito window? That seemed to help eliminate some cached data issues I saw from previous experiments.

Hope your next session much more enjoyable!

1 Like

Jason took a look at the robot to figure out how to get it on the Misty-Staff network. He asked Brad to take a look who also wasn’t able to get the robot to respond. So, Brad pushed “a new robot app” to the robot and it’s now working. I don’t know, yet, if “new robot app” means one that is not-yet-for-public consumption or whether it just means “I reinstalled the current for-release app on the robot”.

1 Like