Robot Not a Dev? Buy Now
Not a Dev?

Misty Community Forum

Can't connect blockly or drive my robot - but *can* ping it

Tried to go through the out of box today at my house. Set WiFi credentials properly (at least got the “Success!” message and an IP address). Tried to drive using joy-stick – no motor action. Tried Blockly and Javascript API – neither worked (timeouts in the console). Ping’d the robot at the IP address I’d been given (10.0.1.34) and got a successful response to the ping.

  • 820 Board is on (blue LED is confirmed on)
  • Confirmed that laptop and mobile phone are both on same WiFi network that robot is supposed to be on.

Any trouble-shooting tips from here? Should I be doing something with port 2010 on my WiFi router?

One additional note… The Javascript API and Blockly I’m using is circa CES – i.e. I haven’t downloaded and unpacked the API client from the getting started guide. I’m going to do so just to try that.

When I used the current Getting Started Guide (in the forum), there was a link to the Javascript API, so I just clicked that. Still no joy in terms of connecting to the robot. When I issued a Drive command, though, I did notice a different error in the console v. the time-out errors I’ve received throughout. Pasted below:

Mixed Content: The page at ‘https://misty:MistyRocks!@api-client.mistyrobotics.io/’ was loaded over HTTPS, but requested an insecure XMLHttpRequest endpoint ‘http://10.0.1.34:2010/api/DriveTime’. This request has been blocked; the content must be served over HTTPS.
(anonymous)
send @ jquery-3.2.1.min.js:4
ajax @ jquery-3.2.1.min.js:4
PostCommand @ MistyAjax.ts:77
PostAjaxCommand @ MistyAPI.ts:516
DriveTimeByValue @ MistyAPI.ts:163
DriveTimeByValue @ MistyRobot.ts:495
(anonymous) @ SampleUI.js:279
dispatch @ jquery-3.2.1.min.js:3
q.handle @ jquery-3.2.1.min.js:3

I wonder if in our attempt to make it easier to load blockly and javascript API, we mixed metaphors between HTTP and HTTPS?

Hi Tim. I’m inviting some folks to help troubleshoot with you. They may invite you into the Slack group to do some real-time troubleshooting as well.

Thx Ben. I’ll be available another 12 minutes - friends over for dinner soon. I can pick up tomorrow.

I don’t believe our robots currently accept an HTTPS connection, depending on what browser you’re using, there might be a simple solution of just allowing an HTTP connection.

Could you try the same process using http://api-client.mistyrobotics.io/ with the same credentials? (notice http instead of https)

And just to confirm: have you had motor movement with any method since getting the robot home? The fact that you’re not able to use the joystick at all is concerning.

1 Like

No motor at all.

The http error only happened after I tried the non-CES JavaScript — ie the one linked from the quick start guide. The original effort was with the regular downloaded API (again, circa CES).