Robot Not a Dev? Pre-order Now
Not a Dev?

Misty Community Forum

Can’t connect on Command Center

I’m trying to connect to misty to check for system updates (it’s been a while) but I can’t seem to get her connected on the command center tab. I can only connect on the skill runner tab.

Thanks for submitting this @lawrence.jasmine - that is a bummer.

Could you try connecting to an older version of the tools so we can try to figure this out.

Misty Robotics / Dev Toolkit / Home (1.1.15.0) or Misty Robotics / SDK / Home (1.1.16.0)

If you can connect to the Command Center using one of those links then maybe you can get your robot version info and share it too.

Hi @lawrence.jasmine - Did those links work for you? If not…I was wondering whether you are able to connect her to the command center using an ethernet cable and ethernet USB dongle (if you happen to have one). If not I’m also curious about whether the eyes are open on Misty when you turn her on and what state are her eyes in?

The links didn’t work any differently . Connecting via Ethernet yielded the same results. When Misty is on her eyes are fully open and I can control it with the app.

Thank you @lawrence.jasmine for checking and also thank you for your patience while we resolve this issue.

I hope it’s ok if you help me check a few more things?

Can you ping Misty on her IP address and see whether you can get a response?
Could you also open a browser and enter in this in the URL http://<IP Address>/api/device see whether you get a response?

From where are you getting the IP address? Are you on the same network as the robot (for example if the robot is on a guest network and you’re on a staff network it will not work)?

Are you on a network you’ve connected to the robot before? The reason I ask is because some networks are configured to not allow peer to peer communication (for example public wifi hotspots, hotel networks, guest networks, etc).

When you used the USB-to-ethernet did you use the IP for the USB for ethernet to try to connect? How did you obtain this? Did you plug the USB-to-ethernet into your router or did you do a point to point from your computer to the robot?

1 Like

I’m on my home network and I’m getting the IP from the Misty app. I followed these instrctions to get the IP when using this documentation

I’m getting a response when i ping by not when i got to http:///api/device

Example from terminal
64 bytes from : icmp_seq=0 ttl=64 time=347.594 ms
64 bytes from : icmp_seq=1 ttl=64 time=77.121 ms
64 bytes from : icmp_seq=2 ttl=64 time=173.993 ms
64 bytes from : icmp_seq=3 ttl=64 time=123.786 ms
64 bytes from : icmp_seq=4 ttl=64 time=143.907 ms

Ok, to confirm:

  • You’ve turned on the robot and Misty’s eyes are fully open and look like this:
  • You’ve connected to the robot via the Misty app, connected Misty to your WiFi and obtained the robot’s WiFi IP
  • On your computer, which is connected to the same WiFi network as your robot, you went to Misty Robotics / SDK /Command Center and entered the robot IP address obtained above in the top right box and clicked Connect

Now, if you open the web console (for Chrome on Windows this would be CTRL+SHIFT+J and on a Mac would be CTRL+OPTION+J) what are the errors or messages you see when trying to connect to the IP you provided above?

Hi Jasmine, I believe you have an older prototype unit which is probably causing all these issues. I’m going to follow-up with you through email to confirm this and work on getting you the latest unit. Thank you again for all your patience while working through this issue.